Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

60D mount problem

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

50% OFF new PortraitPro 12, plus EXTRA 5% OFF code EPHZROS414
Leave a Comment
    • «
    • 1
    • »
    oaktree
    oaktree  5 United Kingdom
    18 Mar 2012 - 3:50 PM

    I recently bought a 60D and have just tried my 2 Sigma lens and both are a very tight which they were not in my 10D. Has anyone has had this problem? oaktree.

    Sponsored Links
    Sponsored Links 
    18 Mar 2012 - 3:50 PM

    Join ePHOTOzine for free and remove these adverts.

    SlowSong
    SlowSong e2 Member 53999 forum postsSlowSong vcard England28 Constructive Critique Points
    18 Mar 2012 - 3:53 PM

    Just tried my two Sigmas on the 60D and both fine.

    JackAllTog
    JackAllTog e2 Member 53471 forum postsJackAllTog vcard United Kingdom58 Constructive Critique Points
    20 Mar 2012 - 12:55 PM

    I would have thought a tight fit was better, my 10-20,70-300 and 70mm sigma's are all fine - crisply fitting. but then the canon lenses seem snug as well.

    MarkBroughton
    20 Mar 2012 - 1:14 PM

    My 60D is fine too with Canon and am Sigma 10-20, so sorry not had any problems.

    oaktree
    oaktree  5 United Kingdom
    20 Mar 2012 - 1:48 PM

    I have installed both the lens a few times and they do appear to be an easier and smoother fit now, so no worries! Many thanks for your responses.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.