Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Any Hahnel Giga T Pro users?

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    jembo
    jembo  10104 forum posts United Kingdom
    27 Mar 2012 - 10:23 PM

    I have just purchased one of these (used) and set it up to test. When I press thr 'shutter' button, the remote display lights up and all of the items in the LCD are displayed. The focus is not triggered and the shutter soesn't activate.
    I have tried changing to CH03 but when the shutter is pressed, again everything lights up and the remote reverts to CH02.
    I think it's either a dud, or not a Canon version. Can anyone confirm?

    Sponsored Links
    Sponsored Links 
    27 Mar 2012 - 10:23 PM

    Join ePHOTOzine for free and remove these adverts.

    parallax
    parallax e2 Member 5116 forum postsparallax vcard United Kingdom
    27 Mar 2012 - 11:13 PM

    I have one and it works really well.

    A few pointers:

    Make sure the receiver is tightly screwed to the camera hotshoe.

    Also ensure that the cable that connects to the receiver, is well plugged into the camera body as it sometimes can come loose.

    I have mine set to 02

    It will say on the front base of the packaging whether for Canon or Nikon cameras

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.