Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

anyone used ulltimate_batteries

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    bigpappapumps
    16 Jun 2010 - 10:39 AM

    just got a grip for a d300 3rd party + a battery from these guys........ The gripworks fine and looks and fits a treat. Really good service too but when i went to charge the battery (assumed it came flat) it charged for no more than a few mins before showing fully charged ie solid light on charger not blinking.I then tried it in the grip and worked fine but after few mins showed it needed charging .Ive done this and the charger is showing fully charged again after just a fwe mins .....is the battery duf or am i doing somat wrong???????

    Sponsored Links
    Sponsored Links 
    16 Jun 2010 - 10:39 AM

    Join ePHOTOzine for free and remove these adverts.

    cameracat
    cameracat  108578 forum posts Norfolk Island61 Constructive Critique Points
    16 Jun 2010 - 12:26 PM

    The grip may well be fine, But theres no way I would use a third party battery from an unknown brand, Thats one way to seriously damage your charger and very possibly your camera too.

    There are good 3rd party brands around if you must, But shop around and you can get genuine " EN-EL3e " types for less than 30 quid.....Smile

    looboss
    looboss  73124 forum posts United Kingdom7 Constructive Critique Points
    16 Jun 2010 - 12:44 PM

    sounds like either daf batteries or wrong type of charger being used.

    bigpappapumps
    16 Jun 2010 - 1:05 PM

    thanx guys
    @camaracat wow didnt know that about batteries and charger gonna take it off
    @looboss i got the d300 second hand (greys of westminster) so charger and battery came with it
    to be fair had no probs b4 but new batt looks identical to one i already had (no nikon markins anywhere)
    so im guessing ive been using a 3rd party one anyway

    BigRick
    BigRick  92085 forum posts United Kingdom3 Constructive Critique Points
    16 Jun 2010 - 5:42 PM


    Quote: Thanx guys
    @camaracat wow didnt know that about batteries and charger gonna take it off
    @looboss i got the d300 second hand (greys of westminster) so charger and battery came with it
    to be fair had no probs b4 but new batt looks identical to one i already had (no nikon markins anywhere)
    so im guessing ive been using a 3rd party one anyway

    If it doesnt say Nikon on the battery, then yes, it is third party. Smile

    Artois
    Artois  8405 forum posts United Kingdom1 Constructive Critique Points
    16 Jun 2010 - 7:52 PM

    I had the same problem on my 50d that was less than a year old. I sent it back to WE as it was under warranty and it transpired it was a duff charger.
    Stella

    bigpappapumps
    16 Jun 2010 - 8:13 PM

    thanx or your help everyone, nice to know theres someone to ask!!!!!! cheersWink

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.