Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


Canon 7D. Error 30


danbrann e2
10 476 15
27 Sep 2012 8:03PM
My Canon7D has just developed A code 30 Error . I believe this to be a shutter problem. Does anyone have a solution or has anyone experienced this error? I have had the battery in and out loads of times to no avail. I am beginning to think it seem expensive.
Danny

Join ePHOTOzine for free and remove these adverts.

Ade_Osman e2
11 4.5k 36 England
27 Sep 2012 9:18PM
Had a similar error one of my 50d's a little while back and it was promptly sent off to Colchester Camera's for repair. The shutter had indeed failed and it also need a new mirror box and one or two other sundry items unrelated to the failure. I'm 280 poorer, but the camera came back in tip top health and is almost like new.

Ade
danbrann e2
10 476 15
27 Sep 2012 10:12PM
Cheers Ade. Thank you.
28 Sep 2012 10:19AM
Yikes! How old is your 7D danbrann?
JackAllTog e2
5 3.7k 58 United Kingdom
28 Sep 2012 1:31PM
As well as the main battery is there a small lithium batter inside as well - for a total reset - all your config data, C1 settings etc.
danbrann e2
10 476 15
28 Sep 2012 1:44PM
Cheers folk,
I have now just got back from a trip to Newcastle where I have left the camera with the repair shop.
Danny
Ade_Osman e2
11 4.5k 36 England
28 Sep 2012 2:10PM
My 50d just bleedin well broke down again this morning! Grrrrrrr.......Sad

This time it's showing error 20, which means it's mechanical again!......Just been onto Colchester Cameras and fortunately all their repairs carry a 6 month warranty, so it looks like I'm going to have to post it off again Sad Good job it's only my spare, but that's not the point. Seriously thing about chopping the whole lot in and going over to Nikon, never though I'd ever hear myself say that I can tell you!

Ade SadSadSadSadSad
User_Removed 2 112 Wales
30 Sep 2012 12:51AM
A friend of mine had error 30 then error 20 on his then 6 month old 50D, fortunately just after a wedding shoot when it completely shut down - fortunately, he got it repaired under the warranty - only ever suffered from error 99 when using Sigma lenses on my then 40D but it was a lens fault as it was a brand new DC lens - now only ever use L glass, even my bridge camera has an L lens!
danbrann e2
10 476 15
30 Sep 2012 9:45AM
My repair man said that sometimes it's just a screw which comes loose but whatever I fear it will be an expensive screw.
Danny
saltireblue e2
4 4.1k 26 Norway
30 Sep 2012 12:05PM

Quote:I fear it will be an expensive screw.
Danny


I could comment, Dan, but shall refrain...Wink

Malc
danbrann e2
10 476 15
30 Sep 2012 4:55PM

Quote:I fear it will be an expensive screw.
Danny
I could comment, Dan, but shall refrain...Wink

Malc



I have no idea what you mean....................
danbrann e2
10 476 15
11 Oct 2012 2:09PM
The latest
I have just been to back to pick my camera up. The repair man said he opened the back could not see anything out of place. put it together again and hey presto its working fine. The nice bit at the end of it was that he would not charge me anything. That's what I call service.The company is APM camera repairs in Old Eldon Square Newcastle.
Danny
mohikan22 10 2.2k 1 United Kingdom
11 Oct 2012 2:19PM
Good news, i was keeping an eye on this thread just in case my 7D went t**s up.
adrian_w e2
7 3.4k 4 Scotland
11 Oct 2012 3:47PM

Quote:I fear it will be an expensive screw.
Danny
I could comment, Dan, but shall refrain...Wink

Malc

I have no idea what you mean....................



Boris Becker might.............

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.