Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

canon eos 600 error message


16 Oct 2009 11:05PM
hi all,
i have a canon eos 600 which i bought for a photography course.the camera works fine with my sigma 55-200 EF fit lens but i also have a few m42 lens..
these work fine on my 40D but when i use them on my eos 600 with a m42 EF fit adaptor i keep getting the error message "bc" and the mirror flips up but stays up :?
i was wondering if i might need to get an AF confirm m42 adaptor instead but not sure...
anyone any ideas on how or if i can get my m42 lens to work with this camera????

thanks in advance,dave

Join ePHOTOzine for free and remove these adverts.

boony 8 978 3 United Kingdom
16 Oct 2009 11:44PM
when mine did this it needed a shutter service. was fine after id had it looked at
cmawson 11 271 United Kingdom
17 Oct 2009 3:12AM
If I remember correctly, on the Canon 600 series, 'bc' in the LCD panel along with mirror lock-up, indicates exhausted battery. It should take 1x 2cr5 lithium battery.
Derek3755 7 4 United Kingdom
17 Oct 2009 7:34AM
This isfrom the manual:
Blinking “BC” on the LCD panel
If the battery power falls to a very low level or a camera misoperation or malfunction occurs, “BC” will blink on the LCD panel. In such a case,
follow the procedure below:
( 1 ) Press the battery check button to check the battery power. If the battery power is low, replace the battery.
( 2 ) If the battery power is normal, remove the battery and reload it.
( 3 ) Release the shutter once.
If the “BC” then turns off, the camera is back to normal. However, if this procedure is repeated and “BC” still continues to blink, the camera has a malfunction. Take it to your nearest Canon Service Center.
17 Oct 2009 8:56PM
thanks for the replies everyone..
its a new battery and i`ve only taken 24 shots with it so far.i`ve tried changing it and i`ve checked it several times but still no luck..
i find it odd that when im using my sigma 55-200 1:4-5.6 DC lens it works fine but as soon as i put the m42 adaptor on, the mirror sticks in the up position.even without a lens screwed in.....

looks like im stuck using one lens for the whole year in my photography course :-(

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.