Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


Elements 9 help


NEWDIGIT 3 401 United Kingdom
15 Jul 2013 10:06AM
Forgive me if this is a really stupid question with an obvious answer but I am no computer geek
when opening my elements organiser the home page shows only a series of egg timers, some of the albums open as images whilst others open showing only a series of egg timers.
what am I doing wrong and whats the solution.
Thanks in advance

Join ePHOTOzine for free and remove these adverts.

15 Jul 2013 12:05PM
Is your computer running normally in all other respects?, did you have any other programmes running at the same time?,
it seems as though elements is having trouble importing the photos from your documents/hard drive.
David
StuartAt e2
9 1.0k 6 England
15 Jul 2013 12:37PM
Or is it possible the images have been moved to a different location than when they were imported originally?
NEWDIGIT 3 401 United Kingdom
16 Jul 2013 1:08PM
They store and open ok in Nikon V2 but still only as egg timer in elements very strange
16 Jul 2013 2:23PM
In Elements Organiser under the File drop down click on Watch folders and see if this is set up correctly,
tick the box, enter your photos folder into the box below, at the bottom you have two options, choose which
ever suits you, hope this helps.
David

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.