Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

Fuji x10, x20 built in flash


Paul Morgan e2
13 16.1k 6 England
28 May 2013 6:57PM
If its stone dead its probably just the power supply.

Join ePHOTOzine for free and remove these adverts.

cattyal e2
9 6.4k 6 England
28 May 2013 7:06PM
That has also been replaced - stone dead as it will start up but won't get very far (stone dead was possibly an exaggeration Smile). The hard drive was also replaced - it's been reformatted several times and it will work for a while and then give up the ghost again. It's not worth spending much time on it - I use the Vaio most of the time along with a second monitor which serves my purpose.
Paul Morgan e2
13 16.1k 6 England
28 May 2013 8:50PM
A quick way of finding out if the problem is hardware or software related is to download something like this, and run the operating system from the disc, if you hard drive turns out to be ok you will get access to it.

http://www.ubuntu.com/

http://www.ubuntu.com/download/desktop/try-ubuntu-before-you-install
cattyal e2
9 6.4k 6 England
28 May 2013 9:00PM
I'll give it a go - nothing to lose really Smile But I won't try it tonight - I think a soggy Sunday afternoon would be the best time!

Meanwhile I must order the diffuser .........
Paul Morgan e2
13 16.1k 6 England
28 May 2013 9:47PM
No there`s nothing to loose at all, I even keep a linux CD at hand to use a a rescue CD Smile
cattyal e2
9 6.4k 6 England
28 May 2013 10:20PM
But definitely a weekend job Smile For now though the diffuser has been ordered - whether it'll arrive before the weekend is debatable but it should arrive next week....
Paul Morgan e2
13 16.1k 6 England
28 May 2013 10:22PM
From Powerplanet it generally takes about 3 working days, not bad considering its free postage.
cattyal e2
9 6.4k 6 England
28 May 2013 10:30PM
That'll be Monday then hopefully - fine by me - I'm going to have a busy weekend anyway Smile
Paul Morgan e2
13 16.1k 6 England
29 May 2013 1:49AM
Who knows you might see it Friday.
cattyal e2
9 6.4k 6 England
17 Jun 2013 8:24AM
A bit of a late return - it arrived the following Monday but thanks to 'stuff' going on I've had no opportunity to play properly with it and see if it's any good.

Mind you I did try my old Vivitar digi flash with the X10 the other day and it works a treat - although it's twice the size of the camera Smile
Paul Morgan e2
13 16.1k 6 England
17 Jun 2013 4:58PM
Yes a lot of units will be a bit heavy attached to the x10, I prefer to connect via a lead.
cattyal e2
9 6.4k 6 England
17 Jun 2013 6:16PM
This flash doesn't need a lead so can in fact go anywhere. I've flash bracket somewhere which might work better - it's on my list of things to root out sometime!
Paul Morgan e2
13 16.1k 6 England
18 Jun 2013 6:44PM
How come, has it a built in optical trigger.
cattyal e2
9 6.4k 6 England
18 Jun 2013 6:51PM
Here it is - acts as a slave to any camera with a built in flash - and it's not bad at all.....
Paul Morgan e2
13 16.1k 6 England
18 Jun 2013 6:58PM
Yes that is handy Smile

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.