Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

HELP!!!!! problem with FujiFilm Finepix Z5!

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    Alla
    Alla  6
    26 Sep 2007 - 11:56 AM

    Hello,
    Out of no where, the camera started turning off and kind of acting up. I thought it was a problem with a battery, so I bought a new one.
    The problem remains >> When I turn the camera ON, it makes a loud long beep that doesn't stop until i take the battery out ......PLEASE, DOES ANYONE KNOW WHY IT DOES THAT AND HOW TO FIX IT???????
    Thank you so much ahead of time!
    -A

    Sponsored Links
    Sponsored Links 
    26 Sep 2007 - 11:56 AM

    Join ePHOTOzine for free and remove these adverts.

    User_Removed
    26 Sep 2007 - 5:44 PM

    Tried calling Fuji..?

    Smile

    Alla
    Alla  6
    26 Sep 2007 - 7:25 PM

    Hi,
    Calling them was the first think i did....pointless, couldn't get through.
    I was just wondering if anyone has experienced a similar thing with their FinePix before?

    thank you

    dcash29
    dcash29  81908 forum posts England
    26 Sep 2007 - 11:58 PM

    Strange you cant get through, are you ringing this number?... 01234 217 724 between 9am-5pm.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.