Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Help please with High speed flash and slave

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    Grampy
    Grampy  4507 forum posts England71 Constructive Critique Points
    25 Aug 2014 - 2:47 PM

    Hi everyone,

    I'm trying without any luck to, I have a Canon 580 EXII that is set on high speed flash plus a Yongnuo 568EXII also set on high speed flash.
    Does anyone know with them set on high speed, if one can slave from the other. I'm going around in circles trying to do it.

    I'm using a ECO3 Cable from the camera that fires either one on high speed, when I set the other one to slave it turns off the high speed flash, I don't have a pocket wizard set up and am desperately trying to avoid buying them, even so I'm not sure they would do the job. The shutter speed is 8000th and works fine on the flash connected too the camera

    Any help would be very welcome.

    From tearing my hair out
    Phillip McCordall

    Last Modified By Grampy at 25 Aug 2014 - 2:49 PM
    Sponsored Links
    Sponsored Links 
    25 Aug 2014 - 2:47 PM

    Join ePHOTOzine for free and remove these adverts.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.