Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Missing DVD/CD drive on my laptop???? Urgent help needed!!

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

New PortraitPro 12 SALE + 10% OFF code EPZROS814
Leave a Comment
    • «
    • 1
    • »
    lgc
    lgc  962 forum posts England
    27 Apr 2009 - 11:29 PM

    Can anyone help??? I have had my dvd/cd drive missing on my laptop since january!!! I bought an acer 4920 August last year and in january I started having problems with the drive going missing.
    I have scoured the net and contacted acer customer services ,it seems to be a problem that everyone is having concerning microsofts Vista software and an update that altered the upperfilter and lower filters in the registry. I have tried all the fixes but still my dvd drive only makes the odd guest appearences when I least need it!! and it only plays a dvd, if I try to burn anything to a cd/dvd it dissappears again!!!! does anyone have any advice please????

    Sponsored Links
    Sponsored Links 
    27 Apr 2009 - 11:29 PM

    Join ePHOTOzine for free and remove these adverts.

    strawman
    strawman  1022006 forum posts United Kingdom16 Constructive Critique Points
    27 Apr 2009 - 11:42 PM

    Also try this

    jimthistle73
    28 Apr 2009 - 12:05 AM

    I had this problem, and after hours of fettling and googling, posted on here. Pretty sure it was Chris' advice that sorted it out for me!!

    rbirrell
    rbirrell  9 United Kingdom
    28 Apr 2009 - 11:34 AM

    I had this problem too on Windows Vista Ultimate. I think that it came about from an Apple iTunes/Quicktime update. It took me a while to work it out but I ended up doing a System restore to before the update. needless to say I have lost the updates but atleast my drive is now visible again.

    BernieS
    BernieS  6243 forum posts United Kingdom
    28 Apr 2009 - 3:20 PM

    I also had this problem on my HP lap top with Vista after one of it's regular updates. Also lost the speakers.

    Required a BIOS upgrade to fix as far as I can remember.

    tomcat
    tomcat e2 Member 85912 forum poststomcat vcard United Kingdom15 Constructive Critique Points
    28 Apr 2009 - 5:59 PM

    this is the one that I posted on here yonks ago

    Adrian

    arnieg
    arnieg  10682 forum posts England
    29 Apr 2009 - 6:45 AM

    book marking
    arnie

    lgc
    lgc  962 forum posts England
    29 Apr 2009 - 4:37 PM

    many thanks for the replies,
    I had already tried three of the fixes and had no joy, i tried one from the links provided and this resulted in total meltdown, computer wouldnt start up again so I had to format the laptop back to its factory settings. didnt loose any docs as everything is backed up to my separate hd.
    I think ill just leave it for the moment, I was going to leave this laptop here in brasil for the family to use and get myself a new one when i come back to the uk!!!!
    anyway thanks for the help guys!!!!!

    tomcat
    tomcat e2 Member 85912 forum poststomcat vcard United Kingdom15 Constructive Critique Points
    29 Apr 2009 - 5:41 PM

    would be interesting to know which one you tried.
    The one I posted needs you to follow it implicitly to work

    Adrian

    lgc
    lgc  962 forum posts England
    30 Apr 2009 - 2:35 AM

    I had and have tried again the fix from the site randomfix, Adrian, and still after rebooting the cd/dvd drive doesnt show when you open the computer drives.
    It shows up sometimes but when I try to use the drive it either freezes/crashes and the drives dissapears again. That is what has driven me mad, I have now given up the fight, and have come to live wothout the dvd drive. I know it sounds ridicullous but after trying everything, I think the only thing i could do now would be to take it in for repair.

    lgc
    lgc  962 forum posts England
    30 Apr 2009 - 2:49 AM

    Adrian if you look down the list of peoples comments on the page (randomfix) you will come across a guy named scanner, i have exactly the same problem as he does. I have removed all the programs like NTI and nero and itunes and still nothing. vista home premium came preinstalled along with NTI when i bought the laptop. I even tried removing vista and installing xp but vista wouldnt let me, and also because I didnt have a drive I couldnt use the xp cd. I even tried booting it of a separate hard drive and still no joy. A nightmare!!

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.