Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

New Sigma 120-300 f2.8 sport and non locking Sigma 1.4 TC

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    User_Removed
    15 Jul 2013 - 2:21 PM

    Hi,

    Anyone ever had an issue with a TC failing to physically lock into position on a lens.

    I have the new Sigma 120-300 f2.8 sport (Nice) and a sigma 1.4 DG EX TC that does not lock into position, that final click, and now the D3 body fails to sense the lens hence no autofocus/Aperature control etc so the pass through is not working. The lens does work fine on the D3 body so does point to the TC.

    I've given both parts a good visual and cannot see any damage however it just doesn't align. The lens is new however TC is a few years old , unfortunately I don't have another Sigma lens to try it with to see which is the culprit, i.e. if lens can send it back, if TC wwould it be worth getting it sent toff to Sigma for a repair?

    Any assistance would be really appreciated.

    -Monty

    Sponsored Links
    Sponsored Links 
    15 Jul 2013 - 2:21 PM

    Join ePHOTOzine for free and remove these adverts.

    richmowil
    richmowil e2 Member 5240 forum postsrichmowil vcard England1 Constructive Critique Points
    15 Jul 2013 - 3:22 PM

    Can't really help you - I have the 100-300F4 and 1.4 DG EX TC and its has worked fine for 5 years or more! I use it with a D300s. Sorry!!

    Coventryphotog
    Coventryphotog Junior Member 1149 forum posts United Kingdom
    15 Jul 2013 - 11:44 PM

    Never had that problem with my 300 prime and 1.4 + 2x TC's

    the following will probably not help, but it's perhaps worth a look Smile

    http://www.sigmaphoto.com/teleconverter-compatibility

    in case the link is removed before you view - sigmaphoto.com/teleconverter-compatibility

    User_Removed
    16 Jul 2013 - 9:25 AM

    Thanks Gents.

    I've checked the Sigma web site already and both are compatible, however as this is a brand new Signal lens wanted to just make sure this is not a manufacturing issue that has already been seen.

    I've taken the plunge of buying another Sigma TC, if this works will send the other one off for repair and put it up on ebay etc. Can't wait as needed for another weekend of sport so hopefully it's the TC and not the lens.

    Will keep you posted.

    -Monty

    Coventryphotog
    Coventryphotog Junior Member 1149 forum posts United Kingdom
    16 Jul 2013 - 11:09 AM

    Hope it works out for you Smile

    arhb
    arhb e2 Member 72149 forum postsarhb vcard United Kingdom67 Constructive Critique Points
    16 Jul 2013 - 11:23 AM

    Sigma should exchange your faulty 1.4tc for one that does work, as it was not fit for purpose, using express delivery.
    Another QC issue with Sigma...

    Coventryphotog
    Coventryphotog Junior Member 1149 forum posts United Kingdom
    16 Jul 2013 - 6:00 PM

    Read again lol

    User_Removed
    24 Jul 2013 - 7:53 PM

    Well the 2nd sigma 1.4 TC I purchased off ebay works fine, so thankfully is an issue with the TC not the new Sigma lens.

    Spoke to Sigma and they are happy to take a look at my old one let's see what they say.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.