Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


Nikon D70 mirror lock up problem


Maddie 9 2.7k 2 United Kingdom
1 Jan 2006 12:27PM
last week i was taking pictures on the beach when i noticed error flahing on top of the camera.
It would not take another picture, i have checked and the mirror lock is not on, but every other shot error flashes up and mirror locks again.
Has any one had this problem or can advice me as to what to do!! thanks

Join ePHOTOzine for free and remove these adverts.

StrayCat e2
10 15.0k 2 Canada
1 Jan 2006 12:33PM
Maddie, I haven't had that problem, but I did have everything freeze up once, couldn't even turn the camera off. I removed the battery and put it back in, and everything has been ok since. Have you looked at the troubleshooting section in the back of the manual?
Maddie 9 2.7k 2 United Kingdom
1 Jan 2006 12:37PM
thanks denny, i have changed the battery and its still the same!
sillyconguru 10 4.4k
1 Jan 2006 12:39PM
Sounds like it's f**ked to me.
snapbandit 10 2.2k 3 Northern Ireland
1 Jan 2006 12:43PM
Sorry to hear of your problems & not wanting to be a pessimist, but my D70 locked the mirror up and would not reset by changing battery, pressing the small 'reset' button on the bottom or by changing lenses/cards or anything else I could think of.

I contacted Nikon & they said to send it back to them as none of the resets worked. when I got it back a few weeks later the service note mentioned replacing the lens aperture actuator on the lens mount, thankfully it was fixed under warranty as it was 1 year & 1 week old.

HTH

JB
Rob_Taylor 10 659 5 Wales
1 Jan 2006 12:47PM
My D70 froze up once, took me a while to figure it out. I'd changed lenses and the aperture wasn't locked on the new lens. This won't be applicable if you're using a 'g' lens or equivilent though.
Maddie 9 2.7k 2 United Kingdom
1 Jan 2006 12:51PM
thanks jb and bobsy, ive changed lenses and tried resetting, but it is still showing error and although working every other shot it isnt actually taking a picture!
snapbandit 10 2.2k 3 Northern Ireland
1 Jan 2006 12:53PM
IIRC if the aperture ring is not at min then you get a 'FEE' error on the top LCD (I sometimes get it on my 300mm lens as it's easy to accidentally move the ring when removing the lens.)

the error I got on the LCD was 'ERR' and would not let the camera reset.

JB
Maddie 9 2.7k 2 United Kingdom
1 Jan 2006 12:59PM
Hi Jb it comes up as Err so its not the lens,looks like Nikon may have to look at it, any ideas how much they charge!!
snapbandit 10 2.2k 3 Northern Ireland
1 Jan 2006 1:03PM
Sorry, mine was only just over a year old and when I phoned them they said to get it to them quickly and were good enough to fix it under warranty.

The person I talked to on the phone was very helpful though & they may be able to advise.

JB
andrewjen 9 99 United Kingdom
1 Jan 2006 1:55PM
Hi Maddie had exactly the same problem as you discribed tried everything different lens, batteries, mem cards phoned Nikon service centre said the only thing to do was send it back to them for repair, took about 3 weeks has been ok since.
Mine was covered by warranty so dont know how much it would be

is it covered by insurance ?

Andy
Maddie 9 2.7k 2 United Kingdom
1 Jan 2006 2:09PM
thanks andy, sounds like the same problem, i will try nikon tomorrow!
User_Removed 10 17.9k 8 Norway
1 Jan 2006 10:18PM
Bookmarking...
andrewjen 9 99 United Kingdom
2 Jan 2006 7:37AM
Maddie how did you get on with Nikon?

Andy
Maddie 9 2.7k 2 United Kingdom
2 Jan 2006 9:20AM
i rang but they are not open today

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.