Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

Nikon Sigma 1.4 tc Owners


29 Jul 2007 3:39PM
Hi can anyone using the sigma 1.4tc nikon fit tell me does ur tc have movement between the joins, mine seems to wobble about.
Link for picture to prolly explain this better is here :
http://www.flickr.com/photo_zoom.gne?id=939266463&size=o

Cheers Gareth

Join ePHOTOzine for free and remove these adverts.

akh e2
10 1.1k 5 United Kingdom
29 Jul 2007 5:10PM
Just checked mine and have no movement at all - solid both on and off the camera. Tested with the Sigma 70-200 which is quite a hefty lens. Looks like you've got a major problem.Sad
Tony
digitall e2
8 238 6 Wales
29 Jul 2007 5:53PM
I have the S50 - 500, with S1.4 TC.
Mine is solid no movement at all.
There are four screws on each side, you might want to try tightening them using a watchmakers screwdriver.

Allan
29 Jul 2007 9:24PM
ok cheers for that folks have emailed sigma uk to get it returned for repair.
Gareth
Frank_Reid e2
9 225 1 United Kingdom
29 Jul 2007 11:28PM
I use mine on the 120-300mm F2,8 and it is as solid as it should be

Frank.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.