Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

Old lens on new camera


johnnyboy114 6 231 106 United Kingdom
18 Nov 2008 11:15AM
Hi again

I have just purchased a really nice 50mm f1.7 lens for my Pentax K100D. I was told it would work no problem on my digital camera in Manual Mode, even though it was made for the old film SLR's. Problem is, I can't seem to get it to work at all on my camera. All I get is the Av sign flashing in the top LCD and in the viewfinder it just keeps flashing "F--" constantly, with no other information in there and no function. It just won't work in any way, let alone take any photos.

Can someone tell me if I am doing anything wrong or is it that this clearly isn't working?


Any information on this would be great as its a very nice looking lens and seems to function really well, but can't seem to get anything out of it.

Thanks in advance

John

Join ePHOTOzine for free and remove these adverts.

spt 10 89 Scotland
18 Nov 2008 11:39AM
I use a few old lenses successfully on my K100D. It works well. You can even use the Shake Reduction mode, if you have set the focal length of the lens in the menu that should appear when you switch the camera on with a manual lens attached.

Set the camera to manual focus with the switch next to the lens mount. The green hexagon focus indicator in the viewfinder will light up when the central point is in focus

If the lens is marked SMC-A

then you should set the aperture ring on the lens to the 'A' position (you may have to press a button to get it into this position). You can then control the aperture from the camera and can use the aperture and shutter priority modes.

If there is no 'A' position on the lens

You need to go to the 'Custom settings' menu on your camera and set 'Using Aperture Ring' to permitted (this doesn't affect anything else - you can leave it set. I don't know why it's not on by default).

Set the camera to manual exposure ('M' mode).

To take a picture: set the aperture on the lens, compose and focus your picture. If you want to use the camera light meter then press the 'AE-L' button to meter the exposure (this quickly stops down the lens and meters it, and sets the shutter speed). Take your picture.

It sounds a bit complicated, but once you've done it once it's pretty quick - just one extra button to press to meter the exposure before taking the picture. The aperture set on the lens will never appear on the camera panel or in the data attached to the image files because the camera doesn't actually know what aperture was used.
johnnyboy114 6 231 106 United Kingdom
18 Nov 2008 1:17PM

Quote:I use a few old lenses successfully on my K100D. It works well. You can even use the Shake Reduction mode, if you have set the focal length of the lens in the menu that should appear when you switch the camera on with a manual lens attached.

Set the camera to manual focus with the switch next to the lens mount. The green hexagon focus indicator in the viewfinder will light up when the central point is in focus

If the lens is marked SMC-A

then you should set the aperture ring on the lens to the 'A' position (you may have to press a button to get it into this position). You can then control the aperture from the camera and can use the aperture and shutter priority modes.

If there is no 'A' position on the lens

You need to go to the 'Custom settings' menu on your camera and set 'Using Aperture Ring' to permitted (this doesn't affect anything else - you can leave it set. I don't know why it's not on by default).

Set the camera to manual exposure ('M' mode).

To take a picture: set the aperture on the lens, compose and focus your picture. If you want to use the camera light meter then press the 'AE-L' button to meter the exposure (this quickly stops down the lens and meters it, and sets the shutter speed). Take your picture.

It sounds a bit complicated, but once you've done it once it's pretty quick - just one extra button to press to meter the exposure before taking the picture. The aperture set on the lens will never appear on the camera panel or in the data attached to the image files because the camera doesn't actually know what aperture was used.



Right oh, thanks fof that. I will give what you said all a go and see what that does. MUCH appreciated for the info and I will get back to you on how things go!

Cheers

J
johnnyboy114 6 231 106 United Kingdom
18 Nov 2008 1:26PM

Quote:I use a few old lenses successfully on my K100D. It works well. You can even use the Shake Reduction mode, if you have set the focal length of the lens in the menu that should appear when you switch the camera on with a manual lens attached.

Set the camera to manual focus with the switch next to the lens mount. The green hexagon focus indicator in the viewfinder will light up when the central point is in focus

If the lens is marked SMC-A

then you should set the aperture ring on the lens to the 'A' position (you may have to press a button to get it into this position). You can then control the aperture from the camera and can use the aperture and shutter priority modes.

If there is no 'A' position on the lens

You need to go to the 'Custom settings' menu on your camera and set 'Using Aperture Ring' to permitted (this doesn't affect anything else - you can leave it set. I don't know why it's not on by default).

Set the camera to manual exposure ('M' mode).

To take a picture: set the aperture on the lens, compose and focus your picture. If you want to use the camera light meter then press the 'AE-L' button to meter the exposure (this quickly stops down the lens and meters it, and sets the shutter speed). Take your picture.

It sounds a bit complicated, but once you've done it once it's pretty quick - just one extra button to press to meter the exposure before taking the picture. The aperture set on the lens will never appear on the camera panel or in the data attached to the image files because the camera doesn't actually know what aperture was used.



Just tried what you said..........brilliant! Thank you! Just what the doctor ordered!

I knew I did the right thing signing up to this site! Thanks so much for the info!!!

John

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.