Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

panasonic dmc-fz100 preview problem after upgrade


mjojom 2 2
12 Jan 2012 4:11PM
Hi Guys,
I am new here and deciding whether to send my camera for repairs. Before xmas I downloaded and upgraded firmware to 1.2. right after I got problem with previewing the pictures.
When preview button pressed I only got black screen. Ive tested to change picture resolution format, nothing works. camera was rebooted to factory settings still no vial. I have tested 2 different SD cards, formated them with SD formatter, nothing. However, pictures can be downloaded of the SD card to PC just fine.
Can someone help please? Is there way to overwrite and downgrade or reload same firmware?
thank you

Join ePHOTOzine for free and remove these adverts.

digicammad 11 22.0k 37 United Kingdom
12 Jan 2012 4:23PM
Hi Jo, welcome to ePhotozine.

When you were running the update did you see any errors or did the camera power off before the update finished?

A quick Google revealed your post here as the only one talking about problems after the update, so it doesn't look like a general thing. However the fact that the problem only appeared after the update leads me to say don't take it in for repair just yet.

If you can find a copy of the previous version of firmware on the web you should be able to apply that to your camera in the same way as you have done the update. Sometimes manufacturers will prevent you going back, but hopefully the update will tell you that you are on a newer version and ask if you want to update with the older one.

Before you try to update again though, find the factory reset option in your menus and try that. It is possible that the update has simply messed up a config setting. Also, try taking the battery out overnight to see if that resets the camera.

Hope that all makes sense and helps.

Ian
mjojom 2 2
12 Jan 2012 4:43PM
thank you,
update went on fine. and everything else working fine. I reset to factory few times, and had the battery out for more then night. I too downloaded earlier firmware, and I cannot downgrade as because of the version number camera does even go to the flash screen. it apparently only takes newer upgrades. Can anybody hack the firmware so camera think it is 1.3 and let me reflash the thing?
mjojom 2 2
14 Jan 2012 9:47PM
anybody can help here please?

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.