Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Pentax 67ii Winder Jammed!!

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    tg
    tg  1086 forum posts Scotland
    27 Oct 2008 - 11:00 AM

    Can anyone help/advise me?

    I have recently bought a Pentax 67ii film camera and after putting only ten rolls of 120 film through it the winder arm has jammed. The arm has very little movement and will not wind on.....the camera will not take a shot either.

    I have removed the film, changed the batteries, checked the manual, camera settings, tried to fire off the shutter, changed lenses, tried without lenses, tried to 'lock up' the mirror and nothing appears to rectify this problem.

    Has anyone had any similar problems? or are aware of any solutions to the problem, other than have it serviced/repaired which I am likely to do. Is this a common problem?

    Thanks,
    Thomas

    Sponsored Links
    Sponsored Links 
    27 Oct 2008 - 11:00 AM

    Join ePHOTOzine for free and remove these adverts.

    User_Removed
    27 Oct 2008 - 1:44 PM


    Quote: I have removed the film

    ...and that didn't release the winder Tom? How were you able to remove the film? (It's been a looooong time btw - over 20yrs since I had a pair of these beauties - one mine and one the clients)

    tg
    tg  1086 forum posts Scotland
    27 Oct 2008 - 4:11 PM

    Unfortunately, the film was ruined. I managed to extract it whilst the winder was stuck to see if I could rectify the problem but it didn't help.

    KenTaylor
    KenTaylor e2 Member 92971 forum postsKenTaylor vcard United Kingdom2 Constructive Critique Points
    27 Oct 2008 - 10:34 PM

    Looks like it is a problem if you google various sites.
    I once met a tog on location who hads his jam there and then and had to revert to his 5x4.
    Ken

    Just Jas
    Just Jas  1225727 forum posts England1 Constructive Critique Points
    27 Oct 2008 - 11:06 PM


    Quote: I once met a tog on location who hads his jam there and then and had to revert to his 5x4.

    Being a pro tog's not all jam, it seems! Smile

    kenp
    kenp  896 forum posts United Kingdom
    28 Oct 2008 - 9:27 PM

    Go to Pentax User Photography forum!.....ask the same question there and I'm sure someone will have the answer!.......they are a very helpful bunch................Ken

    pentaxpete
    30 Oct 2008 - 12:23 PM

    I am on Pentax User and a Pentax 6x7 Mk ii owner but never had that problem ( YET!) so don't know the cure, sorry.I think you must not 'inch on' the winder as you can with most 35mm cameras-you must only wind with ONE full stroke.Only 'inch'it on as you are loading the fillum,watching for the start mark.

    ablast
    ablast  5 Australia
    16 Jun 2009 - 4:32 PM

    Sounds like the winder mechanism is worn. Unfortunately unless you are able to dismantle and assemble it yourself servicing is the only solution.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.