Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Problems with Panasonic lumix DMC - TZ40 and PNY sdxc memory card

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    peterkin
    peterkin  10619 forum posts England
    28 Jul 2014 - 9:18 PM

    I bought the PNY 64Gb sdxc card as a special offer with the camera and the handbook says the 64 Gb card is compatible. However an error message says 'insert SD card again' but I keep getting that same message after re-insertion. The more I Google for an answer, the more confused I get because I'm told 'do not format the card or it will no longer be sdxc'. I can't format it in the camera anyway because all I keep getting is the 'insert SD card again' message. Always had Olympus and Fuji cameras with xD cards previously and never had any difficulties. Can anyone kindly tell me how to deal with this problem? Thanks.

    Peter

    Sponsored Links
    Sponsored Links 
    28 Jul 2014 - 9:18 PM

    Join ePHOTOzine for free and remove these adverts.

    netta1234
    netta1234 e2 Member 2186 forum postsnetta1234 vcard Wales1 Constructive Critique Points
    28 Jul 2014 - 9:57 PM

    Have you tried taking the battery and card out and then put them back.
    I don't know but try anythingSmile
    NettaSmileSmile

    AndS
    AndS e2 Member 2855 forum postsAndS vcard England
    28 Jul 2014 - 10:03 PM

    Have a look here I had an old laptop that couldnt read an SDXC card so i let the pc format it and then it wouldn't work in my TZ40

    peterkin
    peterkin  10619 forum posts England
    28 Jul 2014 - 10:27 PM

    Thank you for your comments. I've solved it now. I formatted the card (in my card reader) on my laptop running Windows 7 which can format in the exFAT format. When I inserted it in the camera a message said 'cannot use this card which has been formatted in another device' or something like that. I then formatted it in camera and it's now working ok. Thanks again. Smile

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.