Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

Sigma 17-70mm F2.8-4

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

Leave a Comment
    • «
    • 1
    • »
    Emyy
    Emyy  4
    5 Sep 2010 - 8:52 PM

    Hello everyone,

    I am new here. Nice and very useful forum. I am not much in photography, I still have a lot to learn.
    I have got a Sigma 17-70mm F2.8-4 DC Macro OS HSM (Canon Mount) as first lens for 500d body (which i sent it back, planing to get 550D), and I noticed some noise inside the lens, like glass noise, while having in hands moving up & down slowly. The guy from shop said that is normal, is doing that noise the OS. I am asking who has this lens to confirm this noise as normal function of it.
    Thanks

    Sponsored Links
    Sponsored Links 
    5 Sep 2010 - 8:52 PM

    Join ePHOTOzine for free and remove these adverts.

    BigRick
    BigRick  92085 forum posts United Kingdom3 Constructive Critique Points
    5 Sep 2010 - 9:39 PM

    no experience of the lens.... but i wouldnt have thought that that kind of noise is 'normal' in any situation.... the OS wouldnt sound like glass inside it. Smile

    chrisheathcote
    chrisheathcote e2 Member 8241 forum postschrisheathcote vcard United Kingdom
    6 Sep 2010 - 10:11 AM

    Ive recently bought this lens and although i havent used it much yet I havent noticed any strange noises. I will check mine again and let you know. One thing possibly to try is to turn the OS off and see if it still makes the noise. If it is that caausing it turning it off should stop.

    Emyy
    Emyy  4
    6 Sep 2010 - 10:38 AM

    Thanks both of you for you help.

    Quote: Ive recently bought this lens and although i havent used it much yet I havent noticed any strange noises. I will check mine again and let you know. One thing possibly to try is to turn the OS off and see if it still makes the noise. If it is that caausing it turning it off should stop.

    I have tried everything but is the same. Hold it in hand with the front of the lens up and shake slowly side to side (left/right) to see if does any noise. Mine one it does quite annoying.

    chrisheathcote
    chrisheathcote e2 Member 8241 forum postschrisheathcote vcard United Kingdom
    10 Sep 2010 - 9:27 PM

    UPDATE....

    Spent the day with my lens and I'm sorry to say that mine doesn't make any odd sounds. Hope you get it sorted as its a cracking lens, photos will be coming soon

    Emyy
    Emyy  4
    10 Sep 2010 - 10:29 PM

    Good news for you. Are you sure that you have the same, Sigma 17-70mm F2.8-4 DC Macro OS HSM? There are others complaining too. if fact i have received an email from Sigma service regarding this problem and i was told...

    "This is completely normal for OS lens, the image stabilasation works off a floating optic and this is only magnetised by the metering on the camera, so when the lens is off the camera the optic will move about, this will not cause any issues to the optic. When the OS is on the mechanism will make a buzzing noise this will be hearable in a dead quiet room for example, this noise will remain until approx. 20 seconds after the camera is turned off.

    Hope this helps. "

    ..I will see I might send them back.

    MrDennis
    MrDennis  5227 forum posts Wales
    28 Sep 2010 - 2:46 AM

    I got one and I get NO noise. Takes great images on my Canon 7D. More than I can say for the Rubbish 150-500

    biggstu
    biggstu  6 Scotland
    30 May 2011 - 12:32 PM

    I got one of these lenses last week and i am getting the same thing.

    Emyy, did you get a resolution to this after you started this thread?

    I am really pleased with the quality of the images i am getting from the lens, but the noise from the mechanisms moving inside when the lens is off the camera is a little disconcerting. I am not sure if it is worth phoning the shop (warehouse express) to see about getting it replaced, or if i will jsut get a similar response to that from Sigma above.

    Any thoughts would be appreciated.

    Stu

    thermosoflask
    10 Jul 2011 - 11:11 AM

    I to bought this lens this week, never noticed any sounds untill i tried it out , with the lens in a vertical position and gentle shake there is a sound that sounds like floating glass , its not noticable when held horizontally, So i suggest the email you had back from sigma would explain it, the shots i've taken since are jut as good as before i did the shake test. J. xx

    f8
    f8  119169 forum posts England22 Constructive Critique Points
    11 Jul 2011 - 10:01 AM

    Why worry about [i]noises/i] if the end result is good. I have noises of sorts on lots of my lenses some due to fair wear and tear,they still perform OK. Enjoy your photography.

    It sounds like the new car syndrome, with a squeak or a rattle,annoying but they still perform well.Smile

    Mike_Smith
    Mike_Smith e2 Member 7122 forum postsMike_Smith vcard United Kingdom1 Constructive Critique Points
    14 Sep 2012 - 8:21 PM

    i have had this lens for quite a while now, i have got great results from it. But i dont get any noise from it at all whether its on the camera or off.

    • «
    • 1
    • »

    Add a Comment

    You must be a member to leave a comment

    Username:
    Password:
    Remember me:
    Un-tick this box if you want to login each time you visit.