Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

sigma 70-300mm dg f4-5.6


19mart71 6 8 United Kingdom
7 May 2011 4:58PM
I got one of these on ebay for 80, it seemed a good deal at the time with case, filter caps and barely used.

However after 6 weeks the autofocus packed up. It makes a horrible noise. I guess the autofocus has stripped the gears.

Doing a bit of research on the internet, it appears that this is not uncommon, especially on the older models. Beware.

Join ePHOTOzine for free and remove these adverts.

cats_123 e2
10 4.3k 25 Northern Ireland
7 May 2011 5:22PM
touchwood, mine has served me well for a couple of years so far
gazbart 3 3 United Kingdom
8 May 2011 1:58PM
I got one of these for 30 knowing the autofocus wasnt working,Took it apart found the problem was the teeth on the outer focusing ring,about three or four had sort of rounded off,i used a small flat screwdriver to flatten them off again.It spends alot of time on my camera and has been okay since,I called sigma about a new part they were shocked that id actually took it apart and knew what the fault was. Iwas told to call back on the following monday because the spares man wasnt in,but i never bothered as it has been okay
ptaloblue 2 1 South Africa
23 Feb 2012 7:29AM
I recently joined this site on my quest trying to find out why my Sigma 70 -300 has been acting up, like you describe, for a third time. I was convinced that it was because of something I did 'wrong', but it seems to have this inherent problem.
This model was purchased a little bit more than a year ago from a reputable firm.
Perhaps Gazbart has the answer ..!
The only up-side to this problem is that the lens carries a three year guarantee, and I have another two years left!
Broken e2
4 21 England
25 Jan 2013 10:10AM
Yikes! I have had one for a year and love it, but I'm worried about what you're all saying. I got mine on Amazon and fingers x'd it'll be OK, as I am a Sigma fan.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.