Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

silver efex pro


danbrann e2
10 497 15
3 Jan 2013 2:40PM
I am running Windows7 and am having problems installing Silver Efex Pro. Is any one else having this problem@ does anyone know the solution?

Join ePHOTOzine for free and remove these adverts.

AnneWorner e2
7 618 43 United States
3 Jan 2013 3:05PM
Danny, I run Silver on Win7, but it works well for me. The folks at NIK are very helpful btw, in case you don't get an answer to your problem here.
Daffy1 e2
7 337 Ireland
3 Jan 2013 4:02PM
No problems at present but I did have one awhile ago with Lightroom4.0 (I think) it wouldn't open as a plug in. Sorted with the lastest Lightroom. Damian
KenTaylor e2
10 3.0k 2 United Kingdom
3 Jan 2013 4:23PM
No problem with LR 4 & Win 7 and all works well with Win 8
ade_mcfade e2
10 15.1k 216 England
3 Jan 2013 4:57PM
ok here too danny... you didn't get the Mac version by accident?
redsnappa e2
12 2.0k United Kingdom
3 Jan 2013 6:18PM
what sort or problems/errors are you experiencing?
danbrann e2
10 497 15
3 Jan 2013 7:32PM
It appears to install it, I then select the Mono conversion I like say..high structure.but then it does not add the layer or any processing at all.
User_Removed 5 4.6k 1 Scotland
5 Jan 2013 4:21PM
Are you accessing it from Lightroom of CS?

In CS it does not behave the same way as ColorEfexPro4 does. ColorEfexPro automatically opens as a new layer in CS whereas SilverEfexPro works on whichever layer you are currently open in. (I think).

I rarely use SEP2 in CS, prefering to use it from within Lightroom 4. Conversely I almost always use CEP4 from within CS6.
Nick_w e2
7 4.1k 99 England
5 Jan 2013 4:56PM
Is it on a laptop? I have the same problem on - Dell Inspiron 1542, it's something to do with the graphics card (or lack of) couldn't find a way round it, sorrySad (works a dream on the PC)

I always use CS5 to runSilver EFEX, and open as smart object Wink
danbrann e2
10 497 15
6 Jan 2013 1:58PM
Thank you everyone. Nick it is a Pc and I am no nearer to an answer. I have my guru working on it at the moment. I will let you all know what transpires.
MrDennis e2
5 247 Wales
24 Jan 2013 1:08AM
You might need to put the serial number in via photoshop when you open Silver Efex Pro in it..
Phil_Restan e2
9 280 9 Scotland
24 Jan 2013 7:41AM

Quote:Are you accessing it from Lightroom of CS?

In CS it does not behave the same way as ColorEfexPro4 does. ColorEfexPro automatically opens as a new layer in CS whereas SilverEfexPro works on whichever layer you are currently open in. (I think).

I rarely use SEP2 in CS, prefering to use it from within Lightroom 4. Conversely I almost always use CEP4 from within CS6.



Mine always opens a new layer from ps, I'm on win 8 and cs5 and sep 1

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.