Login or Join Now

Upload your photos, chat, win prizes and much more

Username:
Password:
Remember Me

Can't Access your Account?

New to ePHOTOzine? Join ePHOTOzine for free!

Like 0

TalkTalk Broadband. Any problems today (8th) ?

Join Now

Join ePHOTOzine, the friendliest photography community.

Upload photos, chat with photographers, win prizes and much more for free!

LouiseTopp
18 Nov 2013 - 9:36 AM


Quote: Anyone else in EPZ who has TalkTalk broadband suffered any problems?

Yes I left because their customer service is bloody awful, and none of their staff can speak very good English. I am now with Sky and I have never looked back.


Quote: What a farce phoning these talk centres - spent about 40 mins talking to someone in India


Exactly. They kept me on hold for half an hour when I asked for the code to leave and go onto Sky, in the end nobody came back anyway.

Sponsored Links
Sponsored Links 
18 Nov 2013 - 9:36 AM

Join ePHOTOzine for free and remove these adverts.

polis_928tadw59

Everything is now running fine with the new router. I also have TT security. When searching in Google, etc. the list of sites would have a browsing protection emblem displayed alongside each one, ie. safe- a green circle with a tick therein. These browsing protection symbols have disappeared, although my browsing protection filter is definitely on. Has anyone else with TT noticed this, or has it just disappeared from my screen ?

polis_928tadw59
23 Nov 2013 - 11:09 AM

Any TalkTalk users in here who have noticed that the browsing protection icons (the round circle with the tick inside; to warn if a site on google etc., is safe, doubtful, or otherwise) have disappeared altogether ?

RogBrown
RogBrown  72996 forum posts England10 Constructive Critique Points
23 Nov 2013 - 11:23 AM

I'm on TT but can't say I've ever noticed these. Where do they appear?

polis_928tadw59
23 Nov 2013 - 11:32 AM

Rog, Thanks for the prompt reply. Whenever I googled a subject the list of sites would appear, and to the left of each one was a green circle with a tick inside the circle to show that the site was safe. There was also a small pane to the top left of my screen where you could notify TT of a site. There were 3 options:
1. I consider this site safe. 2. I have no opinion of this site. or 3. I consider this site to be harmful.

RogBrown
RogBrown  72996 forum posts England10 Constructive Critique Points
23 Nov 2013 - 12:20 PM

Nope, not got that & never have had as far as I know. What browser are you using? It may be specific to that browser. I'm on Firefox.

polis_928tadw59
23 Nov 2013 - 12:41 PM

I always use google. But I have just been into TT (My Account) and posted a question in the community section, 'browser protection icons' or similar, and there was a few queries. There seems to be opinion that it does not work with certain browsers. One suggestions was to uninstall F Secure(TT's security) then re-install which may start showing the icons again.
I am not worried as I have opened TT Security and browsing protection is switched on. Coupled with the icons was a warning pane which would come on at time : 'This site is harmful. Do not enter, etc.' and the option "Return to Home Page."

A few months back I attempted to log in to TalkPhotography, and got such a warning. Dear knows why. I contacted TP to let them know, and I belive they followed the matter up with TT security.
One thing which has just come to mind is, could it possibly be down to the new router supplied by TT ?

Last Modified By polis_928tadw59 at 23 Nov 2013 - 12:42 PM
monstersnowman
23 Nov 2013 - 2:12 PM

You can simply do an online service check that will almost certainly point you to an online router upgrade request ... You shoudnt need to speak to anyone or even mail them. I now have my new router .. The service initially was much faster and better wifi .. Theni raninto some awful outages bu it hassettled down th last week and everything is fine for the moment.

polis_928tadw59

Thanks for that monstersnowman. As I have posted, the new router is working A1, with no problems whatsoever. It was only due to the browser items disappearing, that I was getting a bit worried, but opening TT security showed that everything was fine. I will try an online service check later.

polis_928tadw59

Update re TalkTalk security icons missing. They still have not reappeared when using Google. However, I have just used Bing for a search, and the icons were there alongside every item listed. They are as follows :
1. Red circle with cross inside - unsafe. 2. Green circle with 'tick' - safe. 3. Yellow circle with 'i' - warning, 'possibly unsafe' 4. Grey with '?', which I may think will be to inform TT of your opinion of the site.

Why the icons are no longer showing on a google search page I do not know.

RogBrown
RogBrown  72996 forum posts England10 Constructive Critique Points
29 Nov 2013 - 2:28 PM

I just tried Bing but no icons.

Add a Comment

You must be a member to leave a comment

Username:
Password:
Remember me:
Un-tick this box if you want to login each time you visit.