Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


Tamron 70-300 autofocus not working.


Artois 8 405 1 United Kingdom
29 Jul 2009 3:44PM
Hi

My tamron 70-300 just will not autofocus. I have tried it on the 50d and my old 400d and autofocus works on neither. I can manually focus but would like autofocus to work too for grab shots! It makes a grinding noise and I suspect the motor may be faulty. It is only 18 months old.

Any ideas as to what could be wrong? Do you think I will need to send it off for repair? Jessops (where I purchased it) told me it will cost about 25 just to send it off to Tamron for inspection.

Stella

Join ePHOTOzine for free and remove these adverts.

strawman 10 22.0k 16 United Kingdom
29 Jul 2009 4:28PM
Call or EMAIL Tamron service and get the idea of the standard AF motor replacement cost. No experience of Tamron, but Sigma can quote you for STD repairs.

But it is possible that replacement may be lower cost.
I think INTRO 2020 are the UK agents, give them a call 1st.
Artois 8 405 1 United Kingdom
29 Jul 2009 4:37PM
Thank you for info. I knew someone would help! That is what makes this a site worth belonging to.

Stella
steve_p 9 1.1k England
29 Jul 2009 4:59PM

Quote:Jessops (where I purchased it) told me it will cost about 25 just to send it off to Tamron for inspection.


Yes but you will get that credited to the repair bill should you have it done!
Steve

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.