Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


Trouble with Nikon D50 - not taking photos


29 Jan 2013 4:47PM
I used this camera today several time with no problem, then 5minutes after I last used it I went to use it again and it wouldn't take photos. It seems to focus but then not take the picture. After reading some trouble shooting advice on google I found if I pressed the AE-L AF-L button first it would take the photo. I have reset it and tried cleaning lenses and body with a soft cloth but nothing has helped. Any other solutions or anyone had the same problem?!?!
Thanks in advance

Join ePHOTOzine for free and remove these adverts.

mikehit e2
5 7.1k 11 United Kingdom
29 Jan 2013 5:24PM
The only thing I can think of is focussing - on Canon models, if it is set in one-shot mode it will not fire until it hits focus. If Nikon do the same, maybe you have de-linked (?) AF from the shutter release button? This would explain why it works when you pres the AF-L button.
Turn the lens to manual focus and see if it fires.
Graysta e2
9 1.1k England
29 Jan 2013 8:08PM
Tried your manual?
janeez e2
6 1.2k 8 United Kingdom
30 Jan 2013 7:04AM
Have you switched the auto focus/manual button over on the front by accident.
30 Jan 2013 7:34AM
Can you take a picture using manual focus?
If yes it is likely the camera is set not to take a picture using autofocus unless it is clearly recognised by the autofocus system. There are a few subjects that autofocus may not detect. The camera can be set not to take a photograph when it cannot detect the intended subject.
30 Jan 2013 9:29AM
Thanks for the possible solutions, It doesn't take photos in manual either, only way it will take them is if I press the AE-L AF-L button first. Have tried everything suggested here and through googling and can't for the life of me work it out, pretty sure I didn't press or alter anything as it worked fine 5 mins before, which makes me think it may be mechanical!?? My next problem is to find a camera shop to take a look as the only one we had locally was Jessops.
Anyone know of anywhere in Shrophire?
x
janeez e2
6 1.2k 8 United Kingdom
30 Jan 2013 9:47AM
Sounds like the shutter mechanism may have failed. Happened on my old D80. Easily repaired but may cost in region of 100. I used a company called 1st Aid Repairs who were very quick, reasonably priced and did an excellent job. Good communication from them as well and a lot cheaper than many others.
janeez e2
6 1.2k 8 United Kingdom
30 Jan 2013 9:48AM
Update on last comment. You will need to send your camera to them but it is very straightforward and will save you money as well.
KNS 5 106 2 United Kingdom
30 Jan 2013 12:52PM
Go into the menu system of the D50 -

goto the wrench/spanner menu,

enter csm/setup menu item - make it is set to detailed

Back out to main menu

Goto to pencil menu

Goto item 14 (ael/afl)

Change from af - on to ae lock only

And that should sort you out Smile
KNS 5 106 2 United Kingdom
31 Jan 2013 6:44PM
Don't know why I bothered.....that's it with these forums for me I think.
User_Removed 5 4.6k 1 Scotland
31 Jan 2013 8:23PM

Quote:Don't know why I bothered.....that's it with these forums for me I think.


Don't let it get to you Kevin/Seri.

Even if the OP does not have the courtesy to acknowledge your attempt to help, there are possibly many other readers who will pick up some wisdom from your contribution.
oldblokeh e2
3 925 United Kingdom
31 Jan 2013 8:45PM
The OP hasn't logged in since yesterday and may well have no idea that you've offered advice.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.