Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


PRIZES GALORE! Enter The ePHOTOzine Exclusive Christmas Prize Draw; Over £10,000 Worth of Prizes! Plus A Gift For Everybody On Christmas Day!

OMD Cracked Bezel

If you'd like to join this group, either login or register with ePHOTOzine.


Paul Morgan e2
13 16.1k 6 England
28 Nov 2012 10:19PM
Looks like you all need to check yours.

Stumbled upon this thread, and on checking my OMD, I found it to be the same.

http://www.mu-43.com/f42/omd-em5-crack-bottom-bezel-screen-normal-36685

Join ePHOTOzine for free and remove these adverts.

Paul Morgan e2
13 16.1k 6 England
29 Nov 2012 12:05AM
Bumping this.
Carabosse e2
11 39.7k 269 England
29 Nov 2012 12:15AM
There's the faintest of hairline cracks just above the middle screw on mine, but nothing like on that pic. I can barely feel it with my fingernail. Had to use a torch to see it properly. I wouldn't have even noticed it - thanks for the heads up.

Hmm... is it a split - or as has been suggested in the thread on Mu-43, a join between two pieces?

Would be interested to hear what others find.
Pete e2
13 18.7k 96 England
29 Nov 2012 12:23AM
Yes mine's the same. I would never have noticed either.
Paul Morgan e2
13 16.1k 6 England
29 Nov 2012 12:27AM
I would not have noticed it if I had not stumbled upon that thread.

There was an interesting case a while ago, an OMD user`s rear screen cracked, Olympus claimed it was his doing, but he also had these same cracks that are appearing now at the bottom by the screw fixings.

Looks to me this is a manufacturing fault, screws look as if they have been over tightened, the screw on the left side also looks a bit iffy (too tight and bending the bezel)
AnneWorner e2
7 618 43 United States
29 Nov 2012 12:33AM
There are no cracks of any kind on mine - but this is a bit disconcerting to hear about.
Carabosse e2
11 39.7k 269 England
29 Nov 2012 12:47AM
Olympus UK contact details here .
Paul Morgan e2
13 16.1k 6 England
29 Nov 2012 12:51AM
Yes I already have it book marked.

Gave myself a scare thinking I had lost my warranty card, turned out it shares the same card as the supplied kit lens Smile
AnneWorner e2
7 618 43 United States
29 Nov 2012 12:52AM
Could it be caused by using a tripod?
Paul Morgan e2
13 16.1k 6 England
29 Nov 2012 12:54AM
I guess it could but I`ve only used mine with the two part grip fitted.
AnneWorner e2
7 618 43 United States
29 Nov 2012 1:03AM
I just checked the screws on mine Paul, and they are not over-tightened.

They've got a thread on this at DP Review also.
brian1208 e2
11 10.6k 12 United Kingdom
29 Nov 2012 6:06AM
I checked mine when I spotted the thread - no sign of a crack (I've had the grip on for most of the time I've owned the camera)
mdpontin e2
10 6.0k Scotland
29 Nov 2012 7:56AM
Checked mine too - thanks for the heads-up Paul - but I can't see any sign of cracking. I'll check it again later, in better light.
29 Nov 2012 7:59AM
no cracks here Grin never pull/flip screen out, maybe this weakens it
mikehit e2
5 7.1k 11 United Kingdom
29 Nov 2012 9:16AM
On that link in the OP, there seems to me to be some distortion and possibly the start of a crack over the screw on the left as well.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.