Looking for Unique Wall Art? Explore Cameraframe: Extraordinary Frames Crafted with Camera Parts

Bronica ETRS shutter speed problem

collinf 20 1.2k
22 Sep 2003 4:24PM
So, here's the problem:

I (as some already know) have a Broni ETRS. At Stonehenge I discovered a little problem in that the shutter speed defaulted to 1/60 sec no matter what I set the dial to. So, having lost all but 2 pictures I took, I tested the battery power using the Prism head - Dead :o( I have now replaced the battery. Testing it in the prism I know that battery is good.

With no film loaded, the shutter speed still seems to default to 1/60 sec (ish). Does the camera need film in to set the shutter speed or should it do it without film? I have the std 120 back in place.

Thanks all

mad-dogs 20 2.2k England
22 Sep 2003 7:10PM
Having film loaded should make no difference.

Does the camera work OK without the prism head?

Is the prism head set to auto or manual?
Big Bri 22 16.7k United Kingdom
22 Sep 2003 10:21PM
Collin - sorry to hear you lost most of the stonehenge shots. Can't help you with the problem, but if you want to head back to try again, I will come keep you company.
stevenj 19 2.0k England
22 Sep 2003 11:14PM
If only I lived a little closer - I would come and provide the tea and coffee. Bad luck about losing the photos Collin, sorry I can't help with the technical bits...
collinf 20 1.2k
23 Sep 2003 6:37AM
Thanks Bri - I might just have to try and organise another run to Stonehenge. Anyone fancy February?

Mad-dogs - I was kinda hoping I wasn't gonna hear that. It makes no difference whether the prism head or the WLF is fitted, the prism is just a prism, it has no AE controls in. It just gave me a way to check that the battery was working ok in the camera.

Stevenj - Tea sounds good - just put the kettle on for tea :o)
mad-dogs 20 2.2k England
23 Sep 2003 6:55AM
Try another battery - when the battery is low, the camera defaults to a set speed - I think the SQ-A is 500 th. of a sec..

Have you tried it with a different lens?

Have you set the lens to 'T'?
collinf 20 1.2k
23 Sep 2003 6:59AM
I put a new battery in last night, do you think I should try another?

tried it with all three of my lenses.

Dumb q time: What's the T setting? I don't remember seeing it on the lenses.


mad-dogs 20 2.2k England
23 Sep 2003 7:05AM
If the replacement battery id low on charge it may not work properly.

The 'T' setting is a little slider which is under the lens on an SQ-A - not sure if it is the same for ETRS.


collinf 20 1.2k
23 Sep 2003 7:18AM
The replacement battery is brand new - only took it out of the packaging last night when I put it in the camera. I'll try another anyway.

I'll have a look for the T setting and see if it makes a difference.

Thanks for your help Dave.

mad-dogs 20 2.2k England
23 Sep 2003 7:22AM
Have you tried a different lens?
Cleaned the contacts between lens and body?
stan walker 20 578
23 Sep 2003 6:42PM
You have pushed the batt test button OK
It cannot be on T as you have taken 2 shots. You did not say if you had more than one lens, as the shutter speed is controlled by the lens. The body just lifts the mirror. If the contacts are OK and clean, it looks like you have a lens fault.
stan walker 20 578
23 Sep 2003 6:50PM
There is the slight offchance it could be the switching in the body
collinf 20 1.2k
23 Sep 2003 7:29PM
Thanks Stan.

I have three lenses, 50, 75 and 150mm.

The lenses are all set to "A" and I have now tried all three.

If I set the lens (any of them) to "T" then it still seems to fire at 1/500 (Which I now know to be the default speed) and doesn't hold the lens open (as I assume it should) until I release the shutter button.

The battery test button on the side of the body lights the red LED in the view-finder window so I know the battery is ok (although it might not be contacting with the lens properly). I am not confident enough with the camera to have a go at cleaning the contacts myself. :o(

I think I'm gonna have to get it to a dealer to inspect. The only thing I haven't tried is actually loading a film in and seeing if that makes a difference. I don't see how it should though and the manual (yep I've got one and read it three times!) doesn't mention it.

Thanks for your help guys, I'll let you know how I get on. Of course, it could be a case of dumb user syndrome (here's hoping!)

stan walker 20 578
23 Sep 2003 8:53PM
It makes no difference with film in or out.Setting the multiple exposure allows you to see the shutter diaphragm thru the front of the lens. If its the same on all three lens its got to be the body or switch contacts.On "T" after you fire, the shutter stays open until you switch back to "A"
mad-dogs 20 2.2k England
23 Sep 2003 9:14PM
On "T" after you fire, the shutter stays open until you switch back to "A"

It stays open until you **** the shutter by winding the film on.

You can shoot a whole roll of film on the 'T' setting.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.