Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

Exclusive 25% off Affinity Photo: Professional photo editing with no subscription!

canon 400d shutter delay

STEVELIN 10 161 3 Ireland
9 Feb 2012 4:13PM
hi my 400d gas just developed a bit of a problem when i press the sutter button there is a few seconds delay before it takes the shot this has never happened before i thought it might be that the battery was running down so i charged it and its still doing it . once it fires it will shot of the 9 frames per second as it should operate but it just seems slow to fire. iv swaped the lens to see if that had anything to do with it but still the same. any body any ideas.

Join ePHOTOzine for free and remove these adverts.

mikehit 8 8.0k 13 United Kingdom
9 Feb 2012 4:31PM
have you selected time delay by mistake?
robthecamman 6 1.7k United Kingdom
9 Feb 2012 4:34PM
time delay or uv enabled the lift mirror in menu
STEVELIN 10 161 3 Ireland
9 Feb 2012 4:45PM
no iv just checked and i reset camera functions and its still the same
rogerfry 12 543 United Kingdom
9 Feb 2012 5:13PM
Try setting the self timer to see if the delay is the same. If it is, and the delay is still there when you cancel the self timer, maybe there is an electronic problem and it's time for a service. (Incidentally, the frame rate of the 400D is approx 3 frames per second for a maximum of 10 raw shots, not 9 frames a second).

Hope you get it sorted!
STEVELIN 10 161 3 Ireland
9 Feb 2012 5:43PM
no luck roger still the same, it is taking shots ok its just that slight delay that's annoying me, i think you might be right time for a service or an upgrade.
mikehit 8 8.0k 13 United Kingdom
9 Feb 2012 5:52PM
Are you on 1-shot or AI focus? If you are on one shot it will not fire until the AF has locked on so if the camera or the subject is moving, or if the subject is a low-contrast pattern the AF may be hunting and delaying things.
Turn to manual focus or put the camera on a tropd (or table or other support) and try that.
Or switch to MF and hit the shutter button.
STEVELIN 10 161 3 Ireland
9 Feb 2012 6:19PM
thanks mike i think were on to something here when i switched to manual focus the auto focus still worked for the first shot as in i got the beep so it looks like a problem with auto focusing i think a trip to the camera shop as roger said" my be in need of a service"
mikehit 8 8.0k 13 United Kingdom
9 Feb 2012 8:40PM
If you are on manual focus I think you get a focus confirmation beep anyway to confirm you are in focus (check the camera manual) but even if you are not it will still let you fire.
tomcat 12 6.4k 15 United Kingdom
9 Feb 2012 9:18PM
Still think it is a setting problemGrin
STEVELIN 10 161 3 Ireland
9 Feb 2012 9:24PM
iv reset the camera settings and still have the problem dont know its probably something silly that im missing il keep working atSad
STEVELIN 10 161 3 Ireland
9 Feb 2012 9:38PM
checked drive mode it on continuous.
STEVELIN 10 161 3 Ireland
9 Feb 2012 9:50PM
its taking shots but its very sluggish the best way to describe it would be if i was taking bird shots the bird would be gone before it fired its bugging me now!!!
mikehit 8 8.0k 13 United Kingdom
9 Feb 2012 9:58PM
That has addressed the most obvious ones for me. A trip to the shops it is then...
STEVELIN 10 161 3 Ireland
9 Feb 2012 10:17PM
i just said that to the wife have to go to the camera shop in the morning and guess what she said " you aint getting a new one" i said "yes i am im selling your car!!!!!!!" shes just walked off and gone to bed.
time for a nice can of larger!!

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.