GB Sports Photographer & The Panasonic LUMIX S1

Clone and healing tools' "Alt click" are not defined


xwang 10 56 8
2 Jun 2016 10:55AM
Hello,
I found that my clone tool doesn't work on CS6 in the past few days. I had a look of healing tool, it doesn't work either, but Pattern stamp works.
When I clicked "Alt" key these message come up...see the attachments.101858_1464860555.jpg

101858_1464860611.jpg



It has nothing to do with layers, they are single layers.
It has nothing to do with selection, nothing is selected.
It is not keyboard, I just bought a new one yesterday.
I have reset all tools and change brush sizes several times, and held Shift+Ctrl+Alt start PS, also tried manually to click "default"
I have restored computer to the point when the clone stamp tool worked, but it still doesn't work after restoration..
I had a look of driver updates, but I don't know one is which one I need to update, second is if it is a problem caused by the driver, the third is if it has been updated by Microsoft normal updating.
I did downloaded VLC Media player in the past couple of weeks, but I had it before on another compute, it had no problem as I recall, also it has been taken out after I restored the computer.

It happened before,"cured" by restarting computer, but this method doesn't work anymore.
I use PC and Windows 10.

Is there anything else I can try? Please help.
Many thanks.
Jasmine.

Join ePHOTOzine for free and remove these adverts.

Chris_L 5 5.2k United Kingdom
2 Jun 2016 11:10AM
So it thinks that you are clicking to paint and it wants you to hold down Alt while you choose the source, if you are already doing that your Alt key may not be working - or you have a software keymap fault.

Test it in other programs by holding Alt and pressing keys to activate menus etc. Make sure it is behaving as it should elsewhere to see if it's a general system fault or is specific to Ps
xwang 10 56 8
2 Jun 2016 11:44AM
Thanks Chris.
I only use Alt on PS.. How do I test what you mentioned above please?
xwang 10 56 8
2 Jun 2016 12:05PM
And How do I know if it is software keymap fault? What should I do if it is please?
I thought it was my keyboard "Alt" key, so I changed a new keyboard yesterday but the new one still functions the same as the old one.. so I presume it is not the hardware.
Thanks again.
Techno Plus
11 4.1k 8 England
2 Jun 2016 12:10PM
Found this not the same problem but similar, worth a try......
xwang 10 56 8
2 Jun 2016 12:21PM
Thanks Mal.
I had tried this, it's reset tools.
BTW, Re: Chris question above, I just thought the Alt key is working properly, because Pattern stamp works. It needs Alt+right click.
Chris_L 5 5.2k United Kingdom
2 Jun 2016 12:40PM
If your keyboard has a numeric keypad (numbers in a square on the right hand side) you can test alt by making sure numlock is on then reply to this post and while your cursor is in the text box hold down the left alt key and type 0169 on the numeric keypad (may not work the same with the top row number keys so use the numeric keypad).

If you get a copyright symbol: , your Alt key works and you may have learned a useful shortcut at the same time!

You must not let go of alt til you have 'dialled' all the numbers.

Tianshi_angie 4 2.6k England
2 Jun 2016 1:13PM
It could be that you do have a tiny selection on the layer which you are trying to use clone on. Try using 'Deselect' on the layer you are working on then try selecting for clone using the Alt key. I have had this problem in the past when a selection I have made has not cleared properly and a tiny selection - so small it was not visible on the screen being only a few pixels in size - which when cleared allowed me tocontinue with Clone. I hope this works for you.
Tianshi_angie 4 2.6k England
2 Jun 2016 1:33PM
Following on from Chris's advice above it has occurred to me that you may inadvertently changed the setting on your keyboard, particularly as it has happened on two keyboards. The settings that control it will be in your Windows settings and that would explain why two keyboards have 'misbehaved'. After following Chris's advice to get the copyright symbol depending on the outcome you could check that you have the right keyboard settings for your region (UK if you are there, or USA).
xwang 10 56 8
2 Jun 2016 1:50PM

Quote:If you get a copyright symbol: , your Alt key works and you may have learned a useful shortcut at the same time!
Thanks Chris, Alt works, here it is:

Thanks Angie.
It is not selection and layers.
I have tried several photos from RAW, PSD,and JEPG, none of them works.
Chris_L 5 5.2k United Kingdom
2 Jun 2016 2:18PM
All the usual causes like alt-clicking on something that can't be used due to the state of selection or the layer state seem to have been ruled out. Easy enough to load a new image and check which no doubt you've done.

I wonder what other software is running on your pc that might be hijacking the alt key when used with your mouse? Intercepting that combo of alt-click?

In control panel have a look at mouse settings just in case Logitech (or whoever) have one of their 'helpful' macro features activated without you realising. Uninstall any keyboard or mouse software that came on a disk. Use basic Windows drivers - they are good enough for 99.9% of stuff.

Anyone else use the computer apart from you? Do they play Minecraft or the like and have they set the mouse click to behave differently when the alt key is held down?
Philh04 Plus
14 2.1k United Kingdom
2 Jun 2016 2:36PM
All good advice given... I am not sure here as I am on a Mac, but can you trash the preferences file on Windows?

That usually cures most things on Macs anyway as the preference file is rebuilt.

Phil
Jestertheclown 11 8.0k 252 England
2 Jun 2016 3:44PM
Hi Jasmine,
This happens here sometimes (I'm also using CS6).
This probably doesn't help you but I just click on the "OK" box, the box goes away and everything works normally.
I've never queried why the box appears. I just assumed I'd clicked the mouse before the "Alt." key.
Otherwise, I've always just put it down to one of Photoshop's little idiosyncrasies.
Bren.
xwang 10 56 8
2 Jun 2016 4:00PM

Quote:I wonder what other software is running on your pc that might be hijacking the alt key when used with your mouse? Intercepting that combo of alt-click?

I'm sure that you are on the right track Chris, but I just don't know how to find out..."combo of alt-click"? I don't know what it is...
Nobody uses this computer to play games. I sometimes use an old WinTV stick to use it as TV It can't be BBC iPlayer, can it?

Thanks Phil.
Yeah, .. I learnt that PS designed for Mac.
I have done Shift+Ctrl+Alt and open PS.
Tianshi_angie 4 2.6k England
2 Jun 2016 4:13PM
There is a similar question asked here https://www.photoshopgurus.com/forum/photoshop-newbies/40346-alt-key-problem-clone-stamp-tool-doesnt-work-my-environment.html and the answer was really the same suggestion as Chris - another programme has hijacked your Alt key. It might repay looking to see if anything has been added to your programmes recently - since the date when you first had trouble. It could also be malware - try running Malware Bytes - free download - to see if anything pops up.


Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.