Take your photography to the next level and beyond...

  • NEWS
  • REVIEWS
  • INSPIRATION
  • COMMUNITY
  • COMPETITIONS

Why not join for free today?

Join for Free

Your total photography experience starts here


D300s Probs


charlotte 10 34 2 United Kingdom
19 Jan 2012 9:10AM
Hi all,

When I use my MC-30 Remote, I lose the LCD. I can't review my images or the menu info...nothing. The camera is only 6 monthes old and the Remote is brand new from Amazon. Have I pressed some magical button somewhere that I shouldn't have done?

I really hope it's not the body. Has anyone else had the same trouble?

Regards

Charlotte

Join ePHOTOzine for free and remove these adverts.

DeMarCo 5 1
19 Jan 2012 9:30AM
Have you emailed the Nikon UK help desk? Or tried using the master reset?
User_Removed 5 4.6k 1 Scotland
19 Jan 2012 10:01AM
Charlotte,

Apart from the apparently non-functioning LCD, are the images OK?

Can you review them in the LCD once you unscrew the remote?

Are you perhaps inadvertently sliding the remote button up to the locked Bulb setting?
charlotte 10 34 2 United Kingdom
19 Jan 2012 11:02AM
Thanks Martin, I'll drop them a line.

Thanks LeftForum,
Yes, I can view the images once the remote is unconnected and the images are fine. I've played about with the remote and it's not in the locked position. Without the remote, the image immediately appears on the LCD after I've taken the shot as normal.
I'm waiting for a cheaper Phottix N8 to arrive today so that hopefully I can determine whether it's the camera or the remote. Sad

Charlotte

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.