G9 battery keeps going flat


videoman Plus
14 58 1 United Kingdom
9 Oct 2009 3:58PM
Hi Folks,
I've never had any previous problems with my G9 which I've had over 2 years now, but about a month ago I got it out and found the battery was completely flat. I'd been out with it in my pocket, not in a case and assumed it must have switched on in my pocket (the view pics button is on top, so easily pressed) so I just changed the battery for the spare and recharged the original. However, I went to get it out today (it's been lying flat in a drawer for about a week) and the same thing has happened, the (new) battery is flat. I've put in the spare and it's all OK again.
Anybody got any ideas please?
Regards,
Doug.

Join ePHOTOzine for free and remove these adverts.

9 Oct 2009 11:57PM
Hi, could be totally barking up the wrong tree here but as you have no answers I will have a shot in the dark. We use defibrillators in work but have had problems with wear and tear etc on the chargers in the past. The battery chargers were showing fully charged but the batteries which have their own charge indicators were showing two lights out of a possible four ie they were only part charged. Maybe your camera has a similar fault in the charger and is showing a full charge when the batteries are only part charged. In turn the batteries would flatten more quickly. Perhaps you could borrow a charger to see if the charger is faulty? As I mentioned it's just an idea but I hope it helps
regards
Keith
videoman Plus
14 58 1 United Kingdom
10 Oct 2009 12:10AM
Thanks Keith,
A good idea, but not the solution.
Already tried a different battery and charger,
Regards.
mark_delta 11 1.3k
10 Oct 2009 11:04AM
try and Clean the battery contacts inside the camera, failing this a dodgy capacitor on the power board inside the camera may be draining it down .
Fuji cameras often suffer from this problem,
videoman Plus
14 58 1 United Kingdom
10 Oct 2009 3:09PM
Hi Mark,
Thanks for the suggestion, I suppose there could be some dust or dirt tracking between the contacts.
I've just had a look, nothing visible but I've cleaned the complete inside of the battery compartment, so I'll have to wait a week now to see if it's made a difference.
Interesting comment about Fuji cameras, I hope it's not anything on the power board as it's all completely inaccessible!
Regards,
Doug.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.