Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

Help needed

ammo 11 4
14 Jul 2007 11:04AM
I bought an adaptor so i could use my 400 lens which has a m42 screw on my Canon D60, but when i take a pic the display says Err 01 (clean the lens contacts) and no pic is recorded. I have tried the camera on all settings inc manual, any ideas
Thanks in advance.

Join ePHOTOzine for free and remove these adverts.

cameracat 14 8.6k 61 Norfolk Island
14 Jul 2007 12:48PM
Is there anything in the settings Menu, To allow the use of None cpu lens ?

ammo 11 4
14 Jul 2007 1:15PM
I have had a look and cant find anything, tried just about everything but still no joy.
STUARTHILL758 16 37 1 United Kingdom
14 Jul 2007 1:23PM
im sure that you have to set to stop-down mode
keith selmes 14 7.3k 1 United Kingdom
14 Jul 2007 2:29PM
Something wrong with the adapter I think, or maybe not seated properly.
Mine won't give any error message just using an adapter, not in any mode.
Put extension tube between the adapter and the camera, and the err o1 comes up. Switching off and on clears it. However, I don't know why.
With a completely manual extension tube, no electrical contacts, there's no error message.
chris.maddock 17 3.7k United Kingdom
14 Jul 2007 2:50PM
The problem here, in both ammo's and keith's case, is that the camera has a microswitch that tells it is a lens is fitted. If that is tripped, the camera will attempt to communicate with the lens - and will, of course, fail if an EF lens isn't present. Fitting an EF teleconverter but no lens will give the same result, hence Keith's findings.

On the D30 and, I think, the D60 the microswitch is visible behind the front plate of the lens mount, just above the 9 o'clock position looking at the front of the camera. It is pushed clockwise by one lug of the mount on the lens. You can check this by pushing the switch gently with something llike a cocktail stick.
Some adapters have the mounting lug in that corresponding position the same length as on an EF lens, so it trips the microswitch. A little judicial adjustment with a file (on the adapter not the camera, LOL) will resolve it.

I don't know where the switch is on the 5D, it's not visible anywhere. I suspect it might be hidden behind one of the leaf springs within the mount. As my adapter behaves itself perfectly I've never had cause to investigate the 5D too closely.

keith selmes 14 7.3k 1 United Kingdom
14 Jul 2007 3:03PM
5D with a jessops ext tube works fine.
With a Canon ext tube it give the error.
ammo 11 4
15 Jul 2007 10:33PM
Thank you all for your help, i have found the microswitch as suggested by chris.maddock the next challenge is how to modify the adaptor!
chris.maddock 17 3.7k United Kingdom
15 Jul 2007 11:00PM
Glad it's helped. I can't give any definite advice on exactly how much nor where to trim the adaptor since my own one doesn't cause the problem. I only came across it when trying to help someone on another forum several years ago. Because my adaptor didn't but his did give the error we were intrigued enough to have a good look to identify the reason.
I'm pretty sure he used a file to trim a small amount off the offending lug, he certainly didn't say that he'd done otherwise but he did report that he'd got it working.


Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.