50% Off Portrait Pro + An Extra 15% For EPZ Members With Code: EPZ421

Help re why flash unit not working properly


chrish4 15 89
17 Nov 2007 7:29PM
Hi there - just wondering is it a sign that my flash bulb is needing replaced when it is still firing but there is absolutely no effect on the picture. I bought a couple of Bowens Gemini Esprit 500's about 18 months ago & they were serviced about 6 months ago by Bowens - but as yet I've never had to replace flash so I don't know if it is something that gradually wears down in power - I would have expected it just to have gone but I'm baffled as to why still flashing but no real lighting power behind it?

Any help would be great thanks

Christine
JohnHorne 16 1.0k
18 Nov 2007 9:54AM
You can check the output using a flash meter. If the output is OK, then perhaps there is a timing issue. How do you trigger the studio lights ? If you are using a camera with a built in flash then perhaps it is firing a pre-flash which triggers the studio lights before the shutter opens.
chrish4 15 89
18 Nov 2007 10:12AM
Thanks for taking time to reply John - I fire using an infra red trigger and has always been fine - don't have flash meter anymore to measure actual output - but the results onscreen compared to the exact same set up a few days ago show the flash having next to no effect ? Would you agree if it was the flash tube the whole thing wouldn't fire at all?
peter_davey 15 1.4k England
18 Nov 2007 10:24AM
Quick test you can do, get hold of the head - power up to full and point it at the wall - then fire it using the test button - you'll soon see if any light is coming off it - do this with just a normal reflector on it and nothing else.

Then turn the power to minimum - you should see a difference and the reycyle time show be much quicker to.

Once you've established that the head is working or is not then slowly add back in the parts in your system - eg the ir trigger and then the camera.

Out of interest what was the camera set up?
chrish4 15 89
18 Nov 2007 10:36AM
Thanks Peter will try this - about to start a photo shoot (using my trusty old portaflash heads) so will try later this afternoon - the camera was set at 1/200 shutter speed and f8 - which is usually fine for my purposes photographing kids

Thanks again - I will report my progress!!

Christine

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.