Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

Exclusive 25% off Affinity Photo: Professional photo editing with no subscription!

I cannot upload a photo

Hermanus 5 4 South Africa
3 Jun 2013 6:14AM
When I try to upload a photo I get a warning in red that I have the wrong file type. I tried to upload the same photo as yesterday which uploaded perfectly but still the same message . My files are JPEG digital. Any advice here Smile

Join ePHOTOzine for free and remove these adverts.

3 Jun 2013 6:22AM
Having same problem, Herman, think some gremlins have gotten in to the system!
3 Jun 2013 6:27AM
Have just uploaded mine, finally, try now Herman.
cats_123 Plus
14 4.8k 28 Northern Ireland
3 Jun 2013 6:31AM
same here, but think we're back now (06:30am) Grin
Hermanus 5 4 South Africa
3 Jun 2013 6:36AM
Thanx guys ! I am also back in business !Grin
nickthompson 11 158 England
3 Jun 2013 11:15AM
I'm getting the same problem and it's 11.15am.
I am having the same problem. Time now is 13.20pm. SadSad
saltireblue Plus
8 8.1k 33 Norway
17 Jun 2013 1:41PM

Quote:I am having the same problem. Time now is 13.20pm. SadSad

Submit a report - bottom left hand side of the page "Contact Support" then the IT dept. can look at the problem for you.


Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.