Save 40% On inPixio Photo Studio 12 - Now 29.99

Jumping stabilization on Sigma 24-105


27 May 2022 3:14PM
Just bought second hand, is it normal ? maybe possible to fix with somehow ?
https://www.youtube.com/watch?v=j_kAfxKZm_o

Thanks
LenShepherd 14 4.5k United Kingdom
28 May 2022 8:37AM
I think it is difficult to be sure from this video.
It could be that the lens is not being held particularly steadily and a significant IS adjustment is being made after a movement equivalent to reframing the image in the viewfinder.
If you used a tripod to keep the viewfinder image steady the lens likely needs a repair.
If you did not use a tripod then I suggest repeat the test and see if the issue disappears when using a tripod.
30 May 2022 2:34PM
camera was on the table, no movement at all
LenShepherd 14 4.5k United Kingdom
30 May 2022 3:03PM

Quote:camera was on the table, no movement at all

There seems to be a fault.
Can you get your money back?
Philh04 16 2.3k United Kingdom
31 May 2022 7:52AM
Were you holding the shutter button down all the way through? Sigmas OS does jump when activated so if you were pressing and releasing you would get that effect, but, if you were holding the shutter button down the whole video then that would be a fault.
8 Jun 2022 2:45PM
c70 is the video camera, only REC button

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.