Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

Exclusive 25% off Affinity Photo: Professional photo editing with no subscription!

LR 4 upgrade won't install

Camairish 12 1.4k Scotland
14 Nov 2012 7:48PM
Hi, I've downloaded LR 4 as an upgrade to LR 3.5. The download appears in my Adobe folder but when I click 'Install Lightroom 4' nothing happens. Nada. Niet. Zilcho. Not even an error message.
My laptop had no probs with version 3 and has a Intel Core 2 Duo 2.4 GHz processor. I definately have enough RAM but am unsure of my processor.
Does anyone have any ideas please? I downloaded it because version 3.5 doesn't recognise my new OMD files!!

Join ePHOTOzine for free and remove these adverts.

cameracat 14 8.6k 61 Norfolk Island
14 Nov 2012 7:58PM
Try uninstalling the previous version, Then install LR4, What happens is that during the install procedure ( Just love that word LOL Wink ) The program will ask for the serial key, So enter the new one you got with the LR4 upgrade, Then another line will appear where you enter the serial for your OLD version, Do that hit next and its job done, As they say.

Your CPU should be plenty good enough for LR4, I have tested it on much slower stuff, It works just fine....


EDIT: Keep an eye out during the install for mentions of catalogue integration, Seems they have modified the LR4 version, But there is an option or two that they ask you to choose, Choose the one that is best for you.
ensign 10 212 1 United Kingdom
14 Nov 2012 8:42PM
Hi Camaairish,
If I am correct LR4 is build for Vista and above. I had a similar issue and up graded my laptop, well it was a good excuse.
Good Luck.
Camairish 12 1.4k Scotland
14 Nov 2012 9:33PM
Thanks Vince - I tried to uninstall LR 3.6 but the 'system administrator' won't allow it whatever that means. I upgraded from 2.7 to 3.5 without needing to uninstall and they're still all on my PC. My OS is Vista so that should be fine too. It's evenings like this that I miss looking at my slides!!
Railcam 11 675 2 Scotland
14 Nov 2012 9:47PM
My first thoughts were the same as ensign's. It only works with Vista or Win 7. LR4 is not compatible with XP.

Good luck, you will enjoy LR4 when you get it installed.
cameracat 14 8.6k 61 Norfolk Island
14 Nov 2012 10:23PM
If you get the System Administrator thing come up, Just hit the " Continue " Option.....Assuming Vista version has one, I can't remember as I am running Win 7 64bit these days.

Anyhow if sys admin pop up has no continue option, There is another way....Smile

Go to your " Control Panel " click on " User Accounts, The first ( and only one usually ) should be your very own account.

I'm working blind here, Because I no longer have a Vista box to look at, BUT it is very similar to Win 7, So as per Win 7, Whilst your looking at Your user account window.

Look down the list of options below the words " Make Changes To Your User Account ".......>>>>>

The last one at the bottom " Change User Account Control Settings " .......Click on this one.

The next window has a vertical slider in it, At the top it has Always Notify and at the bottom Never Notify, Pull the slider down to NEVER, Then OK that and return to desktop.

Now Un-Install previous version, Then install the new one.

Yes I know that you did not have to do that in previous versions, BUT this upgrade is going to be making a heck of a lot of changes, So without getting to techie, Its wise to get rid of all the grunge data from the older versions, Or all you do is run the risk of corrupted files etc, Sheesh! You got enough trouble running Vista.....LOL...Grin

If all goes well, Return to the user accounts if you like and reset the notify option to the centre position, Personally I leave it off as mostly I know what I'm doing....So don't need silly OS security telling me what to do with my box......!!!

IF you are still having trouble, Maybe your download has become corrupt for some reason, ( It happens more than you think ) So try downloading it again, Then start again.

If all that fails, Get onto Adobes site, Go to support and do a " live chat " with one of their bods, They are quite an agreeable bunch mostly......Smile

After that I'm out of ideas, Short of the old Axe and Window option.....!!!!!

Edit: One last piece of advise, If and or when you get the urge, Or the computer falls over for some reason, Upgrade it to " Windows 7 preferably 64Bit " Because with this OS on your laptop, You will think you have a new machine, Seriously, Same applies to Windows 8 Pro, The cheapo upgrade option is under 25 squid, However Win 8 Pro has a rather stupid interface, Though some like it, Great for those with Touchy Feely displays I suspect, But pretty stupid of a desktop machine......That said you can install a little number called " Start 8 " this gives you back the old super duper Windows 7 desktop interface, Easy Peasy and under a fiver.......Well worth it....Wink
pete146uk 5 25 1 United Kingdom
19 Nov 2012 12:20PM
Cameracat's suggestion re the slider for notifications should do the trick. When you double click the 'uninstall' file in the adobe folder, try right clicking instead. There may be an option to 'Run as administrator'.

Alternatively - Try to uninstall through a 3rd party application such as Ccleaner - you shouldn't need to identify yourself as admin to do this.

Only other thoughts:
The download may not have worked correctly - can you download again?
Did you download the correct version eg 32 or 64 bit? Needs to be the same as your pc.
Restart the PC then double click the install icon - then leave it if it doesn't start straight away! Come back after 30 mins and you'll know whether it's doing anything. If it isn't, look at your processes (ctrl/alt/del) - is there anything listed such as 'Installer' or 'Adobe installer'?

If all else fails - Did you upgrade directly from the Adobe website? They will also post the disks to you (it actually costs less than if you download!). I'm sure they would do this for you as the download hasn't worked.

Let us know how you get on Smile
Camairish 12 1.4k Scotland
20 Nov 2012 7:05PM
Thanks guys - I'm still struggling. Have deleted & re-downloaded but it still won't install. Despite my best efforts and much searching on Google it is proving impossible to access the administrator option on my windows vista - right clicking the prompt command and 'run as administrator' won't work either - entering 'administrator net user/ active: yes' (or whatever it was) also denies me access to the adminstrator account. Very frustrating that I cannot uninstall a program I installed myself.
Will keep looking.
Many thanks for the suggestions, very much appreciated.

Camairish 12 1.4k Scotland
20 Nov 2012 7:21PM
Thanks Pete - Ccleaner downloads fine...........but Windows Vista won't run it because I'm not the administrator. I'll chat to Adobe to see if they can help.
Jestertheclown 9 7.7k 252 England
20 Nov 2012 7:58PM
Hi Ian,
I once had to uninstal and reinstal Lightroom 3.6 as it had stopped working and I had a terrible job getting rid of it.
It sounds as if this won't work either but I prefer it to CCleaner to uninstal things.
I invariably use Revo Uninstaller. which got shot of most of it. I cleared out the rest using 'start> search' and deleting the remaining files manually.
Seems odd that CCleaner won't work because you're not the administrator and I can't see how that can be anything to do with Adobe.
I'm using XP.
pete146uk 5 25 1 United Kingdom
20 Nov 2012 8:52PM
When you right click the Ccleaner icon, do you get an option to run as administrator? What happens when you choose this?

Do you share your computer with other people (ie at least one other person has an account)? If so, is their account the admin account? Can they install it / uninstall?

If you only have your own account, and it is an admin account, yet you can't install, uninstall, run Ccleaner, OR run as admin I'd be tempted to reinstall windows!
Jestertheclown 9 7.7k 252 England
20 Nov 2012 9:02PM
On here, there's a separate 'Admin' account created by Windows by default, whether I want it or not and it's not my account.
Starting the machine in 'safe' mode, I'm given the option to use either account. Could be worth a try?
In fact, given the problems you're having with access, I'd try 'safe' mode anyway.
Camairish 12 1.4k Scotland
20 Nov 2012 9:23PM
Thanks guys - had chat with nice bloke from Adobe who 'took over' my screen, he tried to access/create an admin account to allow me to install Lightroom 4 using this but he had no luck either. He said the problem lies with my PC. He said it wasn't necessary to uninstall LR 3 before installing LR4.
I think reinstalling Windows would be worth a try - I have the original disc. If the computer allows me to uninstall windows!!
Jestertheclown 9 7.7k 252 England
20 Nov 2012 9:35PM

Quote:I think reinstalling Windows would be worth a try

If it will allow you to reinstall Vista from your existing disc and you'll know as soon as you try, it might be an idea to download and install Windows 8 instead?
It's only 25 and money well spent to be rid of Vista, I should have thought.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.