Start your photography store - 30% off Picfair Plus!

Newly acquired used Sigma 50mm f/1.4 Art lens does not auto-focus


steveni54 2 3
23 Sep 2016 4:55PM
This has never happened to me before. I have bought a lot of used lenses via eBay and never have been sent a defective lens. Until today. I bought a "used" Sigma 50mm f/1.4 Art lens from an eBay seller with a 100% sellers rating and it arrived today. And it looks like it is new. But it does not auto focus. Yes, I switched the lens to auto focus mode, and yes my Nikon D810 and Nikon D7000 have nothing wrong with their auto focus (I tried of course with one of my other lenses). The Sigma 50mm is simply dead, nothing happens when I try to focus. I can focus it manually.

I am of course trying to contact the seller via eBay for an explanation and to return the item as defective. But in anticipation that I cannot get anywhere with this and am stuck with the defective lens (he does not accept returns), my question is what can I do about this? Has anyone experienced this problem with a lens? Can it be repaired?

Thanks for help!

Join ePHOTOzine for free and remove these adverts.

23 Sep 2016 5:40PM
Have you tried cleaning the contacts on the lens? The lens may have some condensation in it picked up during postage. Try leaving it in a warmish spot (not in direct sunlight) for a short while. If this fails to fix the problem then contacting the seller is the first option followed by contacting ebay and paypal.
steveni54 2 3
23 Sep 2016 6:17PM
I have tried several times, putting the lens on and off, and the contacts look remarkably clean. My guess from the condition of this lens is that this guy bought a lens that he never got around to using. It is really in new condition, totally clean. My guess also is that there is an internal connection defect, perhaps the M/A switch is defective.

Anyway, the seller replied to me surprisingly quickly and accepted that I return it to him, and it is still under guarantee in his name, so he would be able to get any defect fixed or the lens replaced. Just a lot of bother. For both of us, unfortunately.
arhb Plus
11 3.4k 68 United Kingdom
23 Sep 2016 6:37PM
I bought a brand new 50mm F1.4 sima(non art) which didn't auto fucus, minutes after leaving the shop.
I ended up with the Canon equivalent, with no problems.
steveni54 2 3
23 Sep 2016 7:22PM
Interesting, arhb. Maybe they have a design flaw which causes this to happen often. I still want this Sigma lens, though. It is rated to be super sharp on my camera. I have the Sigma 35mm f/1.4 Art (also bought via eBay used) and it works divinely. I also have the Sigma 105mm f/2.8 macro and it seems flawless as well, and produces really interesting images for me. I will try again as soon as the return is fully settled, to buy this lens.
arhb Plus
11 3.4k 68 United Kingdom
23 Sep 2016 7:59PM
There is an ongoing issue with quality control at Sigma, which I thought was resolved until I read this thread.
When you get a good one, it's awesome, but sometimes they let duff ones through. That shouldn't happen.
steveni54 2 3
23 Sep 2016 8:09PM
This was the story with the Tamron 24-70 f/2.8. I heard many stories about defects but they all seem to be from years ago. Mine is superb.
marvin001 2 3
26 Sep 2016 9:50AM
From my findings, it tells that it is not auto focus..Focusing is completely internal and the front filter threads do not rotate during focusing, making circular polarizer filters easy to use. FTM (Full Time Manual) focusing is supported.
thewilliam 10 6.1k
26 Sep 2016 10:27AM
I've always wondered whether Nikon shares technical info with Sigma (and other lens makers) or Metz when it comes to flash interface. Or do they just buy a Nikon lens or flashgun and do some reverse engineering?


Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.