Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

NIKON D800 Shock

5 Apr 2013 10:15PM
I know its personal preference, but i have never found Nikon bodies (or their buttons) to be overcomplicated.

I haven't had a proper play around with a D800/e but if the controls are based on its predecessors then they are (IMO) pretty intuitive. I'd rather have the buttons than having to delve into the menu in a rushed situation, and of course you can always program the functions to suit your needs.

Interesting about the grip though. I always use a grip on my cameras (unless its built in like the D4, obviously) for convenience and (more importantly) for comfort/balance with longer lenses, so that would be a concern for me if i was to replace the D700 which has a slightly too small grip for my liking

Join ePHOTOzine for free and remove these adverts.

gary.d 15 135 United Kingdom
15 Apr 2013 10:41AM
On a few occasions recently, when I have tried to access to the menu, I get an egg-timer symbol symbol that stays for around ten seconds. I would say it has happened four times now. Obviously not good to wait that long when trying to change something quickly but could it be an indication of something wrong? Just wondering if any other users had experienced the same thing?

mikehit 8 8.0k 13 United Kingdom
15 Apr 2013 10:42AM
have you tried to access the menu immediately after taking some shots? I am just wondering if it is buffering or something similar
gary.d 15 135 United Kingdom
15 Apr 2013 5:52PM
I can confidently say it's not a buffer issue. It has the latest firmware by the way. I don't recall if it exhibited this behaviour before the update, well not around 10 seconds anyway. More like 1-2 seconds.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.