Take your photography to the next level and beyond...

  • NEWS

Why not join for free today?

Join for Free

Your total photography experience starts here

Exclusive 25% off Affinity Photo: Professional photo editing with no subscription!

Opening an image from Lightroom to Photoshop as a smart object

Consulo 13 840 10 Scotland
17 Jan 2013 12:26PM
Hi folks,

Just been watching a couple of tutorial videos and I've seen mention of opening an image you've been working on in LR as a Smart Object in PS. If I right click on a worked on image in LR and go down to mouse over 'Edit In', the option to 'Open as Smart Object in Photoshop' option is greyed out.

Is there some setting that I maybe don't have enabled in LR that is making this option unavailable?


Join ePHOTOzine for free and remove these adverts.

mlewis 13 1.5k United Kingdom
17 Jan 2013 12:50PM
What version of Lightroom and PS do you have? If you have the latest LR and not the latest PS the version of ACR in PS may not be compatible unless you use Process 2010 in Lightroom. This may cause the issue.
Pete Plus
17 18.8k 97 England
17 Jan 2013 12:51PM
Sounds like Lightroom is not recognising Photoshop or Photoshop does not have the necessary update to process the file you're trying to Open as Smart object. Can you open the file directly in Photoshop?
Consulo 13 840 10 Scotland
17 Jan 2013 12:56PM
Sorry, should've included version info.

PS CS5, LR 3. Just downloaded ACR 6.3.

Pete - yes, I can open the file as a TIFF/PSD etc in PS just fine, but not as a smart object.
Pete Plus
17 18.8k 97 England
17 Jan 2013 1:04PM
That kind of puts the problem to the connection between Lightroom and PS then.
Have you checked preferences? Not sure this will be the answer but under File Handling there's a compatibility option which lists Camera Raw. Mine's set at 7.1 or later and works fine
Consulo 13 840 10 Scotland
17 Jan 2013 1:07PM
Just had a look at the preferences you mention Pete and the newest it lists is 5.4 and later. Source of the problem?
Pete Plus
17 18.8k 97 England
17 Jan 2013 1:12PM
Possibly...although it does come under an Import section and you're exporting, but might indicate the two are not in sync. I've not come across this issue before so it's stabs in the dark I'm afraid. Hopefully someone else will be along with the remedy Smile

One other thought - You say you just downloaded ACR 6.3. Is that installed now and have you rebooted the computer since or at least restarted Lightroom?
Consulo 13 840 10 Scotland
17 Jan 2013 1:28PM
Yeah, everything's installed and I just reset - still no joy.
User_Removed 8 4.6k 1 Scotland
17 Jan 2013 4:18PM
No such problem with LR4 and CS6 and I previously experienced no problem with LR4 and CS5.

Just a wee suggestion: The difference between LR3 and LR4 is so massive, in terms of its processing algorithms, that it really is worth the very nominal charge of the upgrade. I wouldn't say quite the same for the CS5/CS6 upgrade unless you are really a "power user" of CS.
17 Jan 2013 7:46PM
I have LR4.3 and PS CS5, and the 'open as Smart object' link is active- you don't need CS6, even going from the latest process edits in LR. I agree the upgrade to LR4 is worth it.
Consulo 13 840 10 Scotland
17 Jan 2013 8:52PM
I'll look into upgrading to LR4. Hopefully that will solve the problem.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.