Amazon Music Unlimited Offer: 3-Months For FREE!

Printer is distorting or re-orienting images


13 Dec 2020 4:57PM
I have a Canon Pro 9000 Mark 11. It has suddenly started to squash images into a small area or to print them smaller and sideways. i.e. A portrait image can be squashed into the bottom of the page (Lightroom) or it is turned through 90 degrees and printed in proportion but half size across the top of the page (Photoshop). I am unable to change the dimensions in Lightroom - in the 'Print' dialogue box the 'cells' toward the bottom of the page remain 'fixed'. Anyone any ideas? I have just updated the driver for the printer but it is still the same.
Railcam 14 900 2 Scotland
13 Dec 2020 5:50PM
First and simplest move is to reinstall the driver. Either from the disk (if the printer came with one) or downloading the latest driver from the Canon site. This often cures strange happenings.
Railcam 14 900 2 Scotland
13 Dec 2020 5:54PM
Sorry, had not read the end of your post. Try the original driver (on the CD). Does he problem occur if printing from other sources? This might help to identify if it is a printer or Lightroom problem.
13 Dec 2020 6:21PM
it sounds like you have the scale setting on the canon print dialogue set to something other than 100% and / or the same for the lightroom print dialogue.

Lightroom is telling the printer to do one thing whereas the driver forces it another way

go into the print settings and check what you have, making sure the paper is the correct size, orientation and scale..

other than that, does it do the same from any other package / word, chrome etc?
13 Dec 2020 7:13PM
Thanks guys for all those thoughts. I have recently updated Windows and it has very kindly 'lost' all my personal files - letters, and addresses. So I actually don't have anything else to print.

It seems as though it may have something to do with the Adobe software being able to 'talk' to my printer - somewhere. I have checked all the print dialogues and they refuse to be changed. I turned everything off and then on again and it worked for one print but then it gets stuck in one format and that can't be changed.
Jestertheclown 12 8.4k 253 England
13 Dec 2020 9:57PM
Try reverting to an earlier version of Photoshop.

The current one's working OK for me (makes a change) but there are people in fora elsewhere reporting issues with it.
Philh04 Plus
15 2.3k United Kingdom
14 Dec 2020 7:45AM
This does seem to be a driver issue, I would certainly try a re-install. If you are running Windows 10 (64 bit) the current driver is ver. 2.75.

Have you tried printing from Canons Print Studio Pro?
Steve1999 4 1 England
14 Dec 2020 8:48AM
Before trying to reinstall the drivers make you have deleted the printer via Device Manager
14 Dec 2020 10:03AM
Thanks for all the help everyone - I shall endeavour to try things out this morning.
14 Dec 2020 11:50AM
Thank you again everyone - took all of your advice on board and at least Lightroom is working properly now. I rarely use Photoshop for printing but tried it and that still seems to be misbehaving. I will delete it and reinstall, hoping that then it will resolve its' issues. Very grateful for such superb thoughts - happy Christmas to you all. Smile

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.