Save 15% On Excire Foto Software With Code: EXCIRE-EP

Problem with my 7D


copek 17 82
30 Sep 2010 4:29PM
hi guys

I've got a problem with my canon 7d, it's a new camera (few months old) and last time I used it it was around one month ago and
I had around 2700 photos done and I switched it on few days ago and started taking photos and now it shows me 8700 photos.
It was off (battery out) for around a month and that's what happend.
what could it be???
User_Removed 12 1.4k England
30 Sep 2010 4:51PM
Th problem is in how you are ascertaining how many photos you have taken.

IMG numbering is rather "dumb".

RTFM.
Nickscape 15 708 9 England
30 Sep 2010 4:59PM
?? Im confused - are you looking at the shutter count or the image numbering ?
copek 17 82
30 Sep 2010 5:17PM
I think shutter count, I'm not sure now
where's shutter count???
Nickscape 15 708 9 England
30 Sep 2010 5:27PM
I think the shutter count is only displayed in the EXIF data of the photos, to view this you may need to download some software to read the extra information from the file.

Had a quick look at Google and im not sure you will be able to find this out on the 7D at the moment.
javam 17 1.1k 19 United Kingdom
30 Sep 2010 6:01PM
If this is the number displayed in the filename either when copied off to your computer or displayed on the image when viewing it back on the camera screen it is just the file numbering, which as Samwise says, is a bit dumb.

To reset it go in to the menus (I do not have my 7D in front of me so this is from memory so may not be spot on) navigate along to the menu that has options that should include 'File Numbering' go in to that and select the manual reset option. Photos should then start numbering from 1 again.

There are a few other options in there, though sadly not as many as my Pentax K20D had.
copek 17 82
30 Sep 2010 8:23PM
why do you think the number jumped from 2700 to 8700 without any reason???
Overread 13 4.1k 19 England
30 Sep 2010 8:30PM
It's either a glitch with the software or ---- someones been snapping away with your camera over the last month and not told you Wink
Montana5 11 57 3 Scotland
30 Sep 2010 9:44PM
I have this happen to my 7D also, I put it down to a software glitch because I use the same 5 or 6 memory cards on 3 different cameras, without formatting each and every time, its not something that bothers me too much.
User_Removed 12 1.4k England
30 Sep 2010 10:26PM
Sigh...
strawman 17 22.2k 16 United Kingdom
30 Sep 2010 10:38PM
The answer is probably that you are using the same memory card on different cameras and your camera has picked up another cameras card count. I have seen it happen with other Canon cameras.
ckristoff 17 994 Wales
30 Sep 2010 11:36PM
It wasn't me guys!!Grin

My other Canon takes film!Wink


Frank.

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.