Sigma 150-500 lens re-call


MikeRC 14 3.6k United Kingdom
12 Jul 2010 11:53AM
Hi...I recently bought a Sigma 150-500 lens. I've not got excellent results with it but I put that down to the photographer and not the lens.
EPZ posted a notice that these lenses with certain serial numbers...mine included..were being re-called for repair.

I have been in touch with Sigma who say that not all the lenses...with certain serial numbers...are being re-called, only the faulty ones.
I thought that this was in keeping with Sigma's normal policy....so why the re-call notice ?.....what's changed ?

While I have no reason to believe my lens is faulty...other than crap pictures...how can I tell ?

I would re-iterate that my serial number is one of the lenses in question.

Any advice appreciated.....Mike

Join ePHOTOzine for free and remove these adverts.

NEWMANP 12 1.6k 574 United Kingdom
12 Jul 2010 12:35PM
i bought one of the faulty models and as no one seemed to believe me at first i assume it was among the first with the problem.

you will sure know if its faulty because its quite obvious.

the problem is on the auto focus. it will focus outwards to infinity but then not focus back to minimum distance.

the one i purchased was replaced with another unit which works well. i havnt checked the serial number on the new one.
Phil
MikeRC 14 3.6k United Kingdom
12 Jul 2010 3:19PM

Quote:the problem is on the auto focus. it will focus outwards to infinity but then not focus back to minimum distance.


...thanks for that Phil...sorry but I don't understand what you mean.

My lens is not particularily slow to focus in fact on a tripod in my garden it appears perfect....do I assume it's ok ?

cheers....Mike
NEWMANP 12 1.6k 574 United Kingdom
12 Jul 2010 6:21PM
focus on something in the distance and then something close to you it should do it all smoothly away from you and then towards you if it only works one way then its a badun
Phil
MikeRC 14 3.6k United Kingdom
12 Jul 2010 6:59PM
cheers Phil....I will try that tomorrow.

....Mike
MikeRC 14 3.6k United Kingdom
13 Jul 2010 4:38PM
Hi again Phil...if I understand correctly and I think I do.....It all works perfect...so no worries there Smile

thanks again.....Mike

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.