Save 50% On Affinity Photo Today!

Triggering Off Camera Flash on Liveview


Coleslaw 15 13.4k 28 Wales
2 Nov 2012 12:18PM
I have a 5D3, a 580EX2, and a Yongnuo flash. I am also using Yongnuo radio triggers for off camera flash stuff.
Now, whenever I am using liveview, the off camera flashes just wouldn't go off when pressing the shutter.
Switch the liveview off, flashes go off fine.
I think it is the same with 5D2. And I am not sure if it is just setting issues, or it just won't work on liveview.

Anyone encounter the same issue or know the solution?

Cheers/

Join ePHOTOzine for free and remove these adverts.

tatkinson1983 13 130
2 Nov 2012 1:31PM
I have the same thing with 5d mkii and using skyport triggers. Won't work with live view annoyingly. I'm sure pocket wizards work in liveview, but not exactly an solution sorry.
ether 8 23 England
2 Nov 2012 6:35PM
I have had the same problem with my 5D mk2 got round it by buying a cheap (Cactus) trigger and connecting it with the PC cord
Paul Morgan 19 19.5k 6 England
2 Nov 2012 6:55PM
Sell the 5d and get an OMD Col Smile

At the mo the giving away free 45mm lens with each purchases.
Coleslaw 15 13.4k 28 Wales
5 Nov 2012 1:14PM
Cheers all.
Hmmmm.... definitely not going to buy PW and still prefer to keep it wireless.... Sad
Paul Morgan 19 19.5k 6 England
5 Nov 2012 5:52PM
Why are you wanting live view with flash Col.
Coleslaw 15 13.4k 28 Wales
5 Nov 2012 6:30PM
Why not? Lol
Paul Morgan 19 19.5k 6 England
5 Nov 2012 6:36PM
Live views a bit slow using mirrors, its probably why your having problems.
Coleslaw 15 13.4k 28 Wales
5 Nov 2012 6:56PM
I have just found the solution.
Set the Silent LV mode to 'disable', problem solved.

Though to be honest, I still have no idea what mode1 and mode 2 are for....LOL

Sign In

You must be a member to leave a comment.

ePHOTOzine, the web's friendliest photography community.

Join For Free

Upload photos, chat with photographers, win prizes and much more.